Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

получить матрицу 7х7 у которой первая строка задается a[1,j]=3j+4; вторая строка задается a[2,j]=j-(3-(1/j)), а каждая следующая строка есть сумма двух

5-9 класс

предыдущих.

псанмпилмпн 08 янв. 2015 г., 19:02:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shemonayeva
08 янв. 2015 г., 19:37:13 (9 лет назад)

var a: array [1..100,1..100] of integer;
i,j,n,m:integer;
Begin
    n:=7;
    m:=7;
    for i:= 1 to n do begin
        for j:= 1 to m do begin
            if (i=1)then a[i,j]:=3*j+4
            else if (i=2)then a[i,j]:=j-3+1/j
            else a[i,j]:=a[i-1,j]+a[i-2,j];
            write(a[i,j]:4,'');
        end;
        writeln;
    end;
End.

Ответить

Другие вопросы из категории

средняя скорость передачи данных по некоторому каналу связи равна 28800 бит/с. Сколько секунд потребуется для передачи по этому каналу цветного

изображения размером 640 х 480 пикселей при условии, что цвет каждого пикселя кодируется 3 байтами?

1) Рассчитайте объем видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с расширением 1024х768 и количеством

отображаемых цветов, равным 16777216. 2)Вы хотите работать с разрешением монитора 1600х1200 пикселей, используя 16 777 216 цветов. В магазине продаются видеокарты с памятью 512Кбайт, 2Мбайт, 4Мбайт, 64Мбайт. Какую из них можно купить для вашей работы? 3) подсчитайте объём данных, передаваемых в секунду от видеопамяти к монитору в режиме 1024х768 пикселей с глубиной цвета 16 битов и частотой обновления экрана 75 Гц.

Читайте также

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.

Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не

больше половины огорода (размеры участков после раздела должны быть целыми и участки прямоугольными). Вывести '1' - если участок деда оказался меньше, '0' - если участки равны.
Входные данные:
Во входном потоке в первой строке заданы целые числа A, B (A, B < 1000).

Выходные данные:
Вывести единственное целое число.

Пример входного файла (input.txt):
8 4

Том Сойеру необходимо покрасить забор с двух сторон, который содержит N досок. Размеры каждой доски А * В (в метрах). На каждый квадратный метр доски

расходуется С кг краски. Каждая банка содержит D кг. Помогите Тому Сойеру определить количество банок краски, которые ему потребуются для покраски забора.
Входные данные:
Во входном потоке в первой строке через пробел заданы пять целых чисел (N, A, B, C, D <= 1000).

Выходные данные:
Вывести единственное число.

Пример входного файла (input.txt):
10 1 1 2 3
Пример выходного файла (output.txt):
14

решить любые 2 задачи, пожалуйста!!! или хотя бы одну в PASKALe

1. Найти те элементы массива, которые равны сумме двух своих соседей. Первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут.
На вход программе сначало подается значение n<=100 – количество элементов в массиве. В следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. Выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных.

2. На вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. Всего будет введено не более 100000 чисел. Подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. В выходных данных всегда должно быть 9 чисел.
3. Текст на английском языке запишите в массив a[1..1000] of char. Помимо английских букв в нем могут встречаться пробелы и знаки препинания. В массиве b [‘A’ ..’Z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. При подсчете строчные и прописные буквы не различать. На вход программе подается значение n<=1000 – количество символов в тексте. В следующей строке входных данных расположены сами символы (без разделителей). Выдайте 26 чисел – значения элементов массива b.
Пример

Входные данные
Выходные данные
12
Hello world!
0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0

4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.
На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

5. В массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. Вложенные циклы не используйте. На вход программе сначала подается значение n<=10000 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы – целые числа, по модулю не превосходящие 30000. Выдайте два искомых числа в порядке неубывания.
6. На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве.



Вы находитесь на странице вопроса "получить матрицу 7х7 у которой первая строка задается a[1,j]=3j+4; вторая строка задается a[2,j]=j-(3-(1/j)), а каждая следующая строка есть сумма двух", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.