Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

элементы исходных массивов создаются генератором случайных чисел так, чтобы созданные значения были как положительные, так и отрицательные

10-11 класс

Lfybkf01 10 дек. 2014 г., 13:31:19 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kosta7300
10 дек. 2014 г., 16:28:53 (9 лет назад)

type mas=array of integer;
var
    a,i,b:mas;
    y:real;

procedure zapoln(var a:mas);
var i,n:integer;
begin
n:=length(a)-1;
for i:=1 to  n do
  begin
  a[i]:=random(10);
  write(a[i],' ');
  end;
writeln;
end;

function sred(a:mas):real;
var i,n,s:integer;
begin
n:=length(a)-1;
for i:=1 to n do  s:=s+a[i];
result:=s/n;
end;

begin
setlength(a,8);
write('Массив А: ');
zapoln(a);
setlength(i,13);
write('Массив I: ');
zapoln(i);
setlength(b,9);
write('Массив B: ');
zapoln(b);
y:=(sred(a)+sred(i)+sred(b))/3;
writeln('Y=',y);
end.  

Ответить

Другие вопросы из категории

Вводится последовательность целых чисел, по абсолютной величине меньших или равны 100. Найти и вывести на печать количество отрицательных чисел и сумму

всех чисел, расположенных после первого нулевого элемента.
Написать на Паскале буду очень благодарен!!

Трамвайный билет имеет шестизначный номер(от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если первая и

последняя цифра билета являются натуральными ( т.е. делятся на 1 и на само себя ).

В процессе преобразования растрового графического файла его объем уменьшился в 2 раза. Сколько цветов было в палитре первоначально, если после

преобразования было получено растровое изображение того же размера в 256-цветовой палитре?

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.

Читайте также

сформулируйте массив содержащий 15 элементов, с помощью датчика случайных чисел. получите новый массив, каждый элемент которого равен квадрату

соответствующего элемента исходного массива. в полученном массиве определите насколько максимальный элемент исходного массива отличается от минимального элемента нового массива. выведите на экран исходные и полученные результаты

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

Определить для массива X(n) алгебраические суммы четных и нечетных элементов массива. Вывести исходный массив и полученные значения. Упорядочить массив X(n

) по возрастанию. Вывести полученный массив. Исходный массив элементов получить с помощью датчика случайных чисел. Значения буквенных переменных задавать с клавиатуры.
Помогите написать программу в QBasic и нарисовать блок-схему(необязательно)



Вы находитесь на странице вопроса "элементы исходных массивов создаются генератором случайных чисел так, чтобы созданные значения были как положительные, так и отрицательные", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.