Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти сумму всех целых трехзначных чисел которые делятся на 3 и 9 или оканчиваются 5

5-9 класс

AnnaGilmanova 22 сент. 2013 г., 5:34:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kukolka8383
22 сент. 2013 г., 7:11:41 (10 лет назад)

var
  i, s: longint;

begin
  s := 0;
  for i := 100 to 999 do
    if (i mod 9 = 0) or (i mod 100 = 5) then s := s + i;
    {Если число делится на 9, то оно делится и на 3}
  Writeln('Сумма равна ', s)
end.

Результат выполнения программы:
Сумма равна 59490


Ответить

Другие вопросы из категории

(используется стобалльная шкала):

Фамилия

Пол

Математика

Химия

Информатика

Биология
Аганян

ж

52

43

82

74
Воронин

м

92

75

93

55
Григорчук

м

66

69

51

68
Роднина

ж

73

51

40

92
Сергеенко

ж

81

83

83

41
Черепанова

ж

94

64

71

20

Сколько записей в данном фрагменте удовлетворяют условию
«Математика > 60 И Информатика > 55»?
В ответе укажите одно число — искомое количество записей.

2. Ниже в табличной форме представлен фрагмент базы данных о результатах тестирования учащихся (используется стобалльная шкала):
Фамилия

Пол

Математика

Химия

Информатика

Биология
Аганян

ж

82

46

32

70
Воронин

м

43

45

74

23
Григорчук

м

54

68

75

83
Роднина

ж

71

56

82

79
Сергеенко

ж

33

74

38

46
Черепанова

ж

18

83

28

61
Сколько записей в данном фрагменте удовлетворяют условию
«Пол=’м’ ИЛИ Химия>Биология»?
В ответе укажите одно число — искомое количество записей.

3. Ниже в табличной форме представлен фрагмент базы данных о стоимости изготовления фотографий.
Вид

Ширина

Высота

Цена
черно-белый

10

13,5

2,80
цветной

10

13,5

3,00
черно-белый

10

15

3,30
цветной

10

15

3,50
черно-белый

15

21

9,20
цветной

15

21

10,00
цветной

20

30

23,00
черно-белый

30

45

44,00
черно-белый

40

60

400,00
цветной

50

75

650,00
Сколько записей в данном фрагменте удовлетворяют условию
(Ширина < 15) И (Вид="черно-белый")?
В ответе укажите одно число — искомое количество записей.

4. Ниже в табличной форме представлен фрагмент базы данных о результатах тестирования учащихся (используется стобалльная шкала):
Фамилия

Пол

Математика

Химия

Информатика

Биология
Аганян

ж

52

43

82

74
Воронин

м

92

75

93

55
Григорчук

м

66

69

51

68
Роднина

ж

73

51

40

92
Сергеенко

ж

81

83

83

41
Черепанова

ж

94

64

71

20

Сколько записей в данном фрагменте удовлетворяют условию
«Пол=’м’ И Химия < 70»?
В ответе укажите одно число — искомое количество записей.

5. Ниже в табличной форме представлен фрагмент базы данных о результатах тестирования учащихся (используется стобалльная шкала):
Фамилия

Пол

Математика

Химия

Информатика

Биология
Аганян

ж

52

43

82

74
Воронин

м

92

75

93

55
Григорчук

м

66

69

51

68
Роднина

ж

73

51

40

92
Сергеенко

ж

81

83

83

41
Черепанова

ж

94

64

71

20

Сколько записей в данном фрагменте удовлетворяют условию
«Пол=’ж’ И Биология > 70»?
В ответе укажите одно число — искомое количество записей.

7. Ниже в табличной форме представлен фрагмент базы данных о результатах тестирования учащихся (используется стобалльная шкала):
Фамилия

Пол

Математика

Химия

Информатика

Биология
Аганян

ж

52

43

82

74
Воронин

м

92

75

93

55
Григорчук

м

66

69

51

68
Роднина

ж

73

51

40

92
Сергеенко

ж

81

83

83

41
Черепанова

ж

94

64

71

20

Сколько записей в данном фрагменте удовлетворяют условию
«Математика > 70 ИЛИ Информатика > 60»?
В ответе укажите одно число — искомое количество записей.

Здесь зашифрована русская пословица. А сколько в ней слов, включая предлоги?



Человек и возвышенность



IQ<10

↓да ↓нет

обойти

А)6 Б)7 В)8 Г)9

Читайте также

1.Найти произведение всех целых чисел от а до 100 (а<100) кратных 17,но не кратных 2 2.Вычислите: 98+96+94+92+90+88+,,,,,+6+4+2

3.Определить и вывести на экран количество трехзначных чисел,которые делятся без остатка на 5 и 21 одновременно.

4.спортсмен пробежал в 1-ый день тренеровки расстояние 10 км. В каждый следующий день он робегал на 3 км больше ,чем в предыдущий. Определить Суммарное расстояние.

5. в Пионерском лагере n отрядов с различным количеством детей. Сколько всего детей в пионерском лагере?

Решите 2 программы. 1) Найдите количество двухзначных чисел, которые делятся на сумму своих цифр. 2) Составьте программу вычисления

количества трехзначных чисел, у которых сумма цифр является чётным числом.

ОЧЕНЬ СРОЧНО!!!

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

1.С клавиатуры вводится 3 числа. Найти сумму только из положительных чисел.

(Тема:Программирование ветвлящихся и цепленных алгоритмов)
2.Дано двухзначное число,найти сумму и произведение его чисел.
(2-ая задача решается с div и mod)
(Тема:Программирование ветвлящихся и цепленных алгоритмов )

Помогите написать программы >< Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:

Найти максимальное натуральное число меньше 5000, которое делится нацело на 39.

Задача 3: 1 марта в банк положили 1000 руб. Каждый месяц вклад увеличивается на 2% от имеющейся суммы.

а) за какой месяц величина процентной надбавки превысит 30 руб.?

б) через сколько месяцев размер вклада превысит 1200 руб.? Заранее спасибо)



Вы находитесь на странице вопроса "Найти сумму всех целых трехзначных чисел которые делятся на 3 и 9 или оканчиваются 5", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.