Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составьте для вычислителя алгоритм, пользуясь которым он запросит последовательность N чисел и сообщит среднее арифметическое.

5-9 класс

Torreto 18 мая 2015 г., 22:26:59 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zp190483sja
18 мая 2015 г., 23:13:48 (8 лет назад)

проверь орфографию и если не будет потом работать измени i:=1 на i:=0

pascal 

var 

    n,z,l:integer;

    a:array[1..30] of integer;

begin

readln('kol-vo chisel-',n);

for i:=1 to n do

begin

readln(a[i]);

l=l+a[i];

end;

z=l/n;

writeln('srednee arifm-',z);

end.

 

Ответить

Другие вопросы из категории

файл размером 5 килобайт передается через некоторое соединение со скоростью 2048 бит в секунду. определите размер файла в байтах который можно передать за

то же время через другое соединение со скоростью 512 бит в секунду. в ответ укажите одно число размер файла в байтах . единицы измерения писать не нужно.

Привет, срочно помогите)
как из 100011 - 1111?

Читайте также

. Система команд исполнителя Вычислитель состоит из двух команд: 1 – прибавить 2 2 – умножить на 3. а) Составьте для Вычислителя алгоритм получения из

числа 2 числа 30. Алгоритм должен включать только команды 1 и 2, и состоять не более чем из 4 команд.

Исполнитель Вычислитель забыл одну из своих старых команд, но зато освоил новую команду и теперь СКИ имеет вид: *2 - умножить на 2 <= - стереть

последнюю цифру С помощью этих команд он может например из числа 68 получить числа 136 и 6. Составьте для вычислителя наиболее короткую программу получения: 1) из числа 361 числа 7 2) из числа 457 числа 14 3) из числа 167 числа 10

Исполнитель Вычислитель забыл одну из своих старых команд, но зато освоил новую команду и теперь его СКИ имеет вид: *2 Умножить

на 2

<=

Стереть последнюю цифру

С помощью этих команд он может, например, из числа 68 получить числа 136 и 6. Составьте для Вычислителя программу получения:

1) Из числа 457 число 14

2) Из числа 167 число 10

Постарайтесь, чтобы в программе было как можно меньше команд.



Вы находитесь на странице вопроса "составьте для вычислителя алгоритм, пользуясь которым он запросит последовательность N чисел и сообщит среднее арифметическое.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.