Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Перестановкой из n чисел называется-последовательность чисел,где каждое число от 1 до n встречается ровно один раз.Перестановка b1,b2...bN является

5-9 класс

обратной перестановкой перестановки a1,a2...aN, если b[ai]=1=i для каждого i от 1 до n.для заданных двух перестановок определите является ли вторая перестановка обратной первой
Формат входных данных
В певой строке входного файла записано одно целое число n (1<=n<=1000)-размер перестановок.Во второй запписаны n целых чисел b1,b2...bN (1<=bi<=n)-вторая перестановка.
Формат выходных данных
В единственной строке выходного файла выведите одно слово "YES",если вторая перестановка является обратной первой.Иначе выведите "NO".

Kukaracha2201 22 февр. 2017 г., 5:06:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastya121002
22 февр. 2017 г., 7:47:46 (7 лет назад)

uses crt;
var i,j,k,n,sum:integer;
a:array[1..100] of integer;
flag:boolean;
begin
flag:=false;
writeln('Input N');
read(n);
writeln('Input elements');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
for j:=1 to n do
for k:=1 to n do
if (i<>j) and (j<>k) and (i<>k) then
if a[i]+a[j]+a[k]=0 then 
f flag=false then
writeln('No');
end.

+ 0 -
Imp2345
22 февр. 2017 г., 10:23:19 (7 лет назад)

Мы судьи с "ЕртисДарына" Ваша школа будет дисквалефецирована! 
Мы нашли вас по вашему 'Ip' коду

Ответить

Другие вопросы из категории

Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада

становится больше. Определите, через сколько лет вклад составит не менее y рублей. Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

В книге 20 страниц, на каждой странице 50 строк, в строке 60 символов. Для кодирования одного символа используется 16 бит.

Сколько таких целых книг поместится на флэшку размером 512Кбайт?

Помогите, срочно

№1,№2,№3

1)

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?

1. Даны числа от 5 до 16. Необходимо вывести на экран (в столбик) удвоенное значение каждого числа.

Пример вывода ответа: 5*2 = 10
6*2 = 12 и т.д.
2) Напишите программу перевода расстояния из метром в сантиметры для значений длин от 1 до 15 метров.

(Информатика. 8 класс. Паскаль)

Самостоятельная работа. 1. Переведите каждое из данных чисел из десятичной системы счисления в двоичную и восьмеричную системы: 45, 123. 2. Переведите

каждое из данных чисел из десятичной системы счисления в восьмеричную и шестнадцатеричную системы: 123, 2012. 3. Переведите в десятичную систему двоичные числа: 101101, 111111.



Вы находитесь на странице вопроса "Перестановкой из n чисел называется-последовательность чисел,где каждое число от 1 до n встречается ровно один раз.Перестановка b1,b2...bN является", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.