Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Автомат отпускает максимум N единиц товара. Известна стоимость одной единицы товара Z и сумма денег, имеющаяся у покупателя S. Сколько единиц товара

10-11 класс

может получить покупатель и какова сдача?

IrinaMilka1998 23 февр. 2014 г., 23:36:50 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rozamimoza1031
24 февр. 2014 г., 2:03:51 (10 лет назад)

var n,z,s,x:integer;
begin
writeln('Vvedite N');
read(n);
writeln('Vvedite Z');
read(z);
writeln('Vvedite S');
read(s);
x:=(n*z);
writeln('Edinis ',x div z);
writeln('Sdacha ',s mod x);
end.

Ответить

Другие вопросы из категории

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".

что можно сделать с файлами
В прямоугольной системе координат даны координаты A (3 3), B (-42 14) C (-2 4)

Найти координаты точки М, где М - середина ВС



Нужна программа в паскале, помогите пожалуйста.

Читайте также

Информатика... Задача №1 Известна сумма денег у покупателя S и стоимость одной единицы товара. Определить сколько единиц товара может приобрести

покупатель и какова сдача? Задача №2 В классе N учеников. После контрольной работы получено А-"5", В-"4", С-"2". Определить процент троек? Задача №3. Заданы координаты №-х вершин треугольника (х1, у1), (х2, у2 ), (х3, у3). Найти периметр и площадь. Задача №4. Дана длина ребра куба. Найти площадь грани, площадь полной поверхности и объём этого куба

В столовой предлагается N комплексных обедов,состоящих из Q блюд.

Известны стоимость и калорийность каждого блюда. Сколько стоят самый
дешевый и самый дорогой обеды? Сколько калорий включает в себя самое
калорийное блюдо? Кто нибудь знает как решить? скиньте пожалуйста файлом, задача решается в XL.

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.



Вы находитесь на странице вопроса "Автомат отпускает максимум N единиц товара. Известна стоимость одной единицы товара Z и сумма денег, имеющаяся у покупателя S. Сколько единиц товара", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.