Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны целые числа, отличные от 0. Признаком завершения ввода будет число 0. Подсчитать, сколько было введено отрицательных трёхзначных чисел.

5-9 класс

I123 09 июля 2013 г., 0:11:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Qqqhoqqq
09 июля 2013 г., 2:44:23 (10 лет назад)

var
  n, count, a: integer;
begin
  repeat
    readln(a);
    if(a <= -100) and (a >= -999) then inc(count);
  until(a = 0);
  writeln('Было введено отрицательных трехзначных чисел: ', count);
end.

Ответить

Другие вопросы из категории

Задача 1. При угадывании целого числа в некотором диапазоне было получено 6 бит информации. Сколько чисел содержит этот диапазон?

Задача 2. Сообщение о том, что ваш друг живет на 10 этаже, несет 4 бита информации. Сколько этажей в доме?
Задача 3. Сообщение о том, что Петя живет во втором подъезде, несет 3 бита информации. Сколько подъездов в доме?

(Pascal) Задача:

Ввести массив из 5 элементов с клавиатуры. Вывести элементы на экран и найти их сумму.
РЕШИТЕ ПОЗЯЗЯ!

Программа это одушевлённое или неодушевлённое,собственное или нарицательное?

Мышь это одушевлённое или одушевлённое,собственное или нарицательно?

Читайте также

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ



Вы находитесь на странице вопроса "Даны целые числа, отличные от 0. Признаком завершения ввода будет число 0. Подсчитать, сколько было введено отрицательных трёхзначных чисел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.