Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

6. Если Y – вещественная переменная, а N – целая, то правилен или нет следующий оператор присваивания: n:=sin(30). (Ответ обосновать)

10-11 класс

Evelisha110399 22 июля 2014 г., 22:51:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ruzilya95
22 июля 2014 г., 23:43:59 (9 лет назад)

Ошибка привидения типов

+ 0 -
Tаgir2001
23 июля 2014 г., 0:57:09 (9 лет назад)

оператор присвоения то правилтный., че ему будет то, а компилятор наверно выдаст nib,re? если нигде не прописано неявное приведение типов. так что фиг его знает

Ответить

Другие вопросы из категории

Читайте также

Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то

выведите их произведение. Если третье и четвёртое числа больше100, то выведите среднее арифметическое всех пяти чисел. Если выполняются одновременно два перечисленных выше условия, то выведите на экран все пять чисел без изменения. Иначе, выведите третье и пятое числа, увеличив их в два раза.

Напишите оператор присваивания, в результате выполнения которого целой переменной н присвоится значение цифры, стоящей в разряде сотен в записи

положительного целого числа к ( например, если к= 28796, то н= 7).
p.s язык Паскаль:)

Задание 3. Решить задачи: 1) Задайте в виде оператора присваивания следующие действия: a) переменной вещественного типа

х присвоить значение, равное полусумме значений а и b;

b) удвоить значение переменной х;

c) переменной целого типа х присвоить значение на 1 меньшее исходного;

d) сменить знак у переменной х на противоположный.

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.



Вы находитесь на странице вопроса "6. Если Y – вещественная переменная, а N – целая, то правилен или нет следующий оператор присваивания: n:=sin(30). (Ответ обосновать)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.