Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Програмированиииииие!!!ПОМОГИТЕ Вводится 5 чисел.подсчитать сколько из них целых,положительных,отрицательных и нулей

10-11 класс

Smv1954 04 апр. 2015 г., 5:56:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МеЛиСсОчКа
04 апр. 2015 г., 8:33:45 (9 лет назад)

Program Chisla;

Uses Crt;

var p,o,z,c,i:integer;

       n:real;        

 

 

begin

    clrscr;

    write('Введите числа: ');

    p:=0;z:=0;o:=0;c:=0;  

    for i:=1 to 5 do

           begin

               readln(n);

                if (n=0) then z:=z+1; // Нуль не ни положительным ни отрицательным ни целым  

                if ((n mod 2)<>0) and (n>0) then p:=p+1;  

 

                if ((n mod 2)<>0) and (n<0) then o:=o+1; 

               if ((n mod 2)=0) and (n>0) then

                          begin

                               p:=p+1;    

 

                               c:=c+1;   

 

                         end;

if ((n mod 2)=0) and (n<0) then

                          begin

                               o:=o+1;    

                               c:=c+1;   

                        end;

      writeln;

      writeln('Положительных чисел: ',p);

 

      writeln('Отрицательных чисел: ',o);

       writeln('Целых чисел: ',c); 

 

        writeln('Нулей: ',z);   

    readkey;

 

end. 

 

 

Ответить

Другие вопросы из категории

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.

Читайте также

Найти сумму двузначных нечетных чисел. Вывести сумму. А также выводить на экран сколько вводилось двузначных чисел и сколько из них

было нечетных. То есть всего должно быть 3 вывода. Помогите пожалуйста!

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Програмированиииииие!!!ПОМОГИТЕ Вводится 5 чисел.подсчитать сколько из них целых,положительных,отрицательных и нулей", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.