Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

(Паскаль)2.Заполнить с клавиатуры массив из 10 элементов. Если

5-9 класс

минимальный элемент находится в первой
половине массива увеличить каждый четный элемент массива в два раза, в противном случае массив
оставить без изменения. Вывести новый
массив на экран в виде строки.

Kinohka 06 марта 2015 г., 12:29:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vsijyjr
06 марта 2015 г., 14:11:17 (9 лет назад)

program chik3;
var a:array[1..1000]of integer;
i,min,l:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
end;
min:=a[1];l:=1;
for i:=2 to 10 do
begin
if(a[i]<min)then begin
min:=a[i];
l:=i;
end;
end;
for i:=1 to 5 do
begin
if(a[i]=min)then l:=-50;
end;
if(l=-50)then begin
for i:=1 to 10 do
begin
if(a[i] mod 2=0)then a[i]:=a[i]*2;
end;
end;
for i:=1 to 10 do
begin
write(a[i],' ');
end;
end.

Ответить

Другие вопросы из категории

Помгите пожалуйста! Найдите ошибки, а то он всякую чепуху считает.Заранее большое спасибо)))) Используя команду ветвления составить программу,

которая определяет, сколько чисел из К являются нечетными.

Program mass;

uses crt;

var i,k:integer;

a:array[1..100] of integer;

begin ClrScr;

k:=0;

randomize;

for i:=1 to 10 do begin

a[i]:=random(10)-5; write( a[i]:3);

if a[i] mod 2=1 then

k:=k+1;

end;

writeln ( 'Кол-во нечетных чисел из K ',k);

readln;

end.

Час Кода как пройти 10 уровень ам няма?

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

(Паскаль)3. Заполнить с клавиатуры массив из 10 элементов. Проверить,

есть ли в массиве одинаковые элементы и
вывести их на экран.

(Паскаль)1.

Заполнить с клавиатуры массив из 10 элементов. Подсчитать количество
положительных и отрицательных элементов массива.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "(Паскаль)2.Заполнить с клавиатуры массив из 10 элементов. Если", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.