Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Создать последовательный файл с полями: а) фамилия б) учреждение в) должность г) месяц. Запрограммировать диалог просмотра созданного файла в поисках

10-11 класс

фамилий получателей, работающих на предприятии. Паскаль.

Vorozhbit84 15 янв. 2017 г., 5:53:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Klaroline
15 янв. 2017 г., 6:39:47 (7 лет назад)

type
  pers = record
    fio: string;
    org: string;
    dolgn: string;
    mes: byte
  end;

var
  person: pers;
  f: Text;
  org2: string;

begin
  Assign(f, 'persons.dat');
  Rewrite(f);
  writeln('Вводите ФИО, организацию, должность, №месяца');
  writeln('Введите 0 для окончания ввода');
  with person do
  begin
    repeat
      readln(fio);
      if fio <> '0' then
        begin
        readln(org);
        readln(dolgn);
        readln(mes);
        writeln(f, fio,#13#10, org, #13#10, dolgn, #13#10, mes)
        end
    until fio = '0';
    Close(f);
    repeat
      writeln('Введите организацию, * - конец ввода');
      readln(org2);
      if org2 <> '*' then
      begin
        Reset(f);
        while not Eof(f) do
        begin
          readln(f,fio);
          readln(f,org);
          readln(f,dolgn);
          readln(f,mes);
          if org = org2 then
            writeln(fio, ' ', dolgn, ' ', mes);
        end;
        Close(f)
      end
    until org2 = '*'
  end;
end.

Ответить

Другие вопросы из категории

Программирование.Язык Паскаль.

Помогите пожалуйста,нужно нарисовать блок схемы и написать программы

1)Дана строка и буква. Определить сколько слов в строке начинается на эту букву.Вывести эти слова.


2)Составить программу,которая в заданном слове с дефисом меняет местами части до и после дефиса

Помогите сделать работу по информатике. Пожалуйста.

......................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу.
............................................................................................
Учусь я на экономиста-бугалтера, так что думаю, моя профессия - это бухгалтер
Просто, объясните что это как это)))
Например: 1.скачай прайс лист 2. выпиши из этой таблицы то-то то-то 3.запиши то-то то-то
В общем так, чтоб мне стало понятно это задание) А то я скачиваю прайс лист, в котором одни наименования и цены, а что за конфигурации - понятия не имею.(

сходства windows и linux не менее 5

Читайте также

помогите решить в SQL

Лабораторная работа №3. DDL
Для таблицы учета информации о филиалах банка: 1. Создать таблицу с 4 полями. Create table 2. Добавить/удалить/переопределить тип данных у столбца. alter 3. Добавить/удалить первичный ключ. 4. Добавить/удалить проверку значения столбца. 5. Создать/удалить значение по умолчанию. 6. Создать таблицу из 6 столбцов , 1 – первичный ключ, 2 – значение по умолчанию, 3 – проверка значения, 4 – ноль, 5 – не ноль, 6 – уникальный. (сразу все ограничения в одном операторе create)_______________________________________________________________________________

ТЕРМІНОВО!!! ДО ЗАВТРА!!!

1. Тема: Обробка символьних рядків (даних типу String)
Завдання: Дано рядок символів, який складається з окремих слів, відокремлених інтервалом. Порахувати:
- кількість слів у рядку;
- кількість голосних букв у слові.

2. Тема: Обробка даних типу запис.
Завдання: скласти програму утворення даних типу запис у вигляді таблиці, з подальшим записом її в текстовий файл для створення довідкової інформації. У програмі передбачити створення слідуючих підпрограм-процедур:
2.1. формування 5-7 елементів масиву типу запис з полями, вказаними у індивідуальному завданні, з послідуючим їх записом у текстовий файл.
2.2. виведення на екран елементів масиву записів у відповідності з індивідуальним завданням.
Індивідуальне завдання: Список робітників підприємства: табельний номер, ПІБ, посада, дата прийняття на роботу, оклад. Роздрукувати дані про техніка, отримавшого найбільшу зарплатню.

Писати на Паскалі.
Тому, хто відповість правильно натисну "Краща відповідь і подякую на сторінці". Спам не писати заради балів.

ЭТО СРОЧНО ПОМОГИТЕ

Напишите программу, которая ответит на вопрос:

Является ли треугольник со сторонами a, b, c равносторонним?
Является ли треугольник со сторонами a, b, c равнобедренным?
Существует ли треугольник со сторонами a, b, c?
Лежит ли точка с координатами a и b в первой координатной четверти?
Являются ли заданные числа b и c квадратом и кубом числа a?
ТРЕБОВАНИЯ:

Программа вводит три вещественных числа и выводит пять строк с ответами на каждый из вопросов 1-5.
ИМЯ ФАЙЛА С ПРОГРАММОЙ = ВАШЕЙ ФАМИЛИИ

Даны две календарные даты. Вычислите количество дней между ними.

Данные вводятся в файл в формате «ДД.ММ.ГГГГ», де ДД – день, ММ – месяц, ГГГГ – год.



Вы находитесь на странице вопроса "Создать последовательный файл с полями: а) фамилия б) учреждение в) должность г) месяц. Запрограммировать диалог просмотра созданного файла в поисках", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.