Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПОМОГИТЕ РЕБЯТА!!! НУЖНО РЕШИТЬ 3 ПРОГРАММЫ!!!

5-9 класс

1) В файле fraza.txt написанно одно предложение. Надо создать программ в Паскаль что-бы он переписывал в другой файл cuvinte.txt те слова из предложении которые начинаются и заканчиваются тот же буквой!!!
Пример: ANA A TACUT SI APA S-A SCURS.
Результат должен быть такой: ANA TACUT APA SCURS

2) В файле numere.txt написан ряд значении типа logint. Надо создать программ который сможет переписывать только цыфры ПАЛИНДРОМ(Palindrom) в файле palindrom.txt

3) В файле fraza.txt написано одно предложение. Надо создать программ который сможет переписывать в файле cuvinte.txt слова Полиндром(Polindrom).
Пример: Предложение - Lupul a baut apa din cana lui ENE.
Результат: APA LUPUL ENE

Tunik1 29 марта 2017 г., 23:13:33 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Uborka
30 марта 2017 г., 0:18:14 (7 лет назад)

Универсальное решение на три задания, запись в файлы доделать самостоятельно

type
    string_array = array[1..200]of string;

var
    a: string_array;
    a_n, i, j: integer;
    s, firstlast, palindrom: string;
    p: boolean;

procedure GetWords(var sa: string_array; var sa_n: integer; s: string);
var
    i: integer; t: string;
begin
    s := s + ' ';
    for i := 1 to length(s) do
    begin
        if s[i] in [' ', ',', '.', ':', ';'] then begin
            if t <> '' then begin
                sa_n := sa_n + 1;
                sa[sa_n] := t;
                t := '';
            end;
        end
        else
            t := t + s[i];
    end;
end;

begin
    read(s);
    GetWords(a, a_n, s);
   
    for i := 1 to a_n do
    begin
        p := true;
        for j := 1 to length(a[i]) div 2 do
            p := p and (a[i][j] = a[i][length(a[i]) - j + 1]);
        if p then
            palindrom := palindrom + a[i] + ' ';
        if a[i][1] = a[i][length(a[i])] then
            firstlast := firstlast + a[i] + ' ';
    end;
   
    writeln(palindrom);
    writeln(firstlast);
end.

Ответить

Другие вопросы из категории

Одномерный

массив


1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2,
7, -3.

2. Составьте блок-схему алгоритма и программу вычисления в массиве A(10)
количества положительных элементов.

3. Составьте программу заполнения и вывода массива, не используя клавиатуру,
числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Заранее спасибо

Задания во вложениях.
№ 15,16

Нужно решить задачи со 2 по 4

Читайте также

Помогите СРОЧНО,нужно написать какие программы в компьюторе мне нра...

Какими программами я люблю пользоваться.....
Например: Я люблю слушать музыку в проигрователе AIMP3.....
Надо буквально 5-6 предложений....И программ примерно 3-4.....
ПОМОГИТЕ.....Зарание БОЛЬШОЕ спасибо*)

Помогите пожалуйста?нужно создать три программы в турбо паскале.

1. Сумма чисел a+b
2.Частное чисел x;y;
3.Произведение чисел a;b;c;d;

Помогите решить эти 16 вариантов, или хотя бы несколько. Что нужно сделать: Составить программу в Pascal ABC( Нужно сделать так, чтобы вы вводили

координаты х и у и программа проверяет, подходит ли эта точка к графику или нет. Пример на 2 фото.
Очень нужно. 80 баллов

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!



Вы находитесь на странице вопроса "ПОМОГИТЕ РЕБЯТА!!! НУЖНО РЕШИТЬ 3 ПРОГРАММЫ!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.