Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите с информатикой, составить блок-схему по паскаль

10-11 класс

Durova96gDurova 13 окт. 2016 г., 20:55:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sugoy1989
13 окт. 2016 г., 21:46:37 (7 лет назад)

1)
var x, y: real;
begin
     readln(x);
     y := sqrt(sqr(x) - 5 * x + 6) / (sqr(x) - 1);
     writeln('y(', x, ') = ', y);
end.

2)
var a, b, c: real;
begin
     readln(a, b, c);
     if ((a > 0) or (b > 0) or (c > 0)) then writeln(a + b + c)
        else
        begin
             if (b > a) then a := b;
             if (c > a) then a := c;
             writeln(a);
        end;
end.

Ответить

Другие вопросы из категории

написать программку.

вводятся 3 числа(отличных друг от друга. определить 2 крайних

Для чего нужно описывать массив в программировании?

Что включает в себя номер и значение элемента массива?

Сделать одномерный массив.

В массив A[N] занесены натуральные числа. Найти сумму тех элементов, каторые кратны данному значению К. Элементы массива вводить с клавиатуры.

Читайте также

Нужно составить блок-схему алгоритма подготовки к сдаче к экзамену.

Я не могу сочинить этот "алгоритм", помогите ;)
Блок-схемы строить не надо, просто описать, что надо делать.

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

Написать программу (в Pascal) и составить блок-схему по задаче: В двумерном массиве произвольной размеренности подсчитать количество элементов, равных

наибольшему элементу в этом массиве. Вывести значение наибольшего элемента.



Вы находитесь на странице вопроса "Помогите с информатикой, составить блок-схему по паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.