Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Доброго времени суток, уважаемые пользователи сайта. Прошу вас помочь с крайне сложным заданием на мое усмотрение, но за достойную награду. Прошу вас

5-9 класс

помочь мне, так как данное задание решит мою оценку в четверти и мне хотелось бы, что бы она была положительна. Суть задания, вы можете рассмотреть на фотографии ниже. Заранее благодарю. Программмы писать в Паскале.

333333345 28 февр. 2014 г., 11:56:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evazany
28 февр. 2014 г., 12:52:35 (10 лет назад)

1)
var
    i: integer;

begin
    writeln('Число':10, 'Квадрат':10);
    for i := 1 to 5 do
        writeln(i:10, i * i:10);
end.

2, 4, 5, 7 - универсальное решение
const
    one_row = true;

var
    a: array[1..100] of integer;
    i, max, min, sum, min_r, max_r, n: integer;

begin
    writeln('Введите длину массива = ');
    read(n);
    writeln('Введите границы значений для элементов массива = ');
    read(min_r, max_r);
    writeln();
   
    for i := 1 to n do
    begin
        a[i] := random(max_r + min_r) - min_r;
        sum := sum + a[i];
       
        if one_row then
            write(a[i], ' ')
        else writeln(a[i]);
       
        if i = 1 then begin
            min := a[i];
            max := a[i];
        end
        else begin
            if max < a[i] then max := a[i];
            if min > a[i] then min := a[i];
        end;
    end;
    writeln();
   
    writeln('Минимум: ', min);
    writeln('Максимум: ', max);
    writeln('Сумма: ', sum);
end.

3)
const
    x_max = 1.3;
    x_min = 0.5;
    x_step = 0.2;

var
    x, y: real;

begin
    writeln('x':10, ' ', 'y':10);
    x := x_min;
    repeat
        y := sqrt(3 * x * x + 5);
        writeln(x:10:1, ' ', y:10:3);
        x := x + x_step;
    until x > x_max;
end.

6)
var
    i: integer;

begin
    for i := 1 to 10 do
        writeln('3 * ',i:2,' = ', 3 * i:2);
end.

8)
var
    x, y: real;

begin
    read(x);
    if x <= 10 then
        y := 21 - x * x
    else y := x * x * x + 45 * x;
    writeln(y);
end.

+ 0 -
123antoxa123
28 февр. 2014 г., 14:24:18 (10 лет назад)

а что бывают отрицательные оценки? вроде меньше 1 оценки нет))

Ответить

Другие вопросы из категории

Номер 130 пожалуйста
между двумя первыми понятиями существует некоторое отношение. между третьим и одним из четырех, приведенных ниже,- такое же (аналогичное) отношение. укажит

е нужное понятие:
машина-мотор = лодка-
река
маяк
парус
волна
роман - глава=стихотворение-
поэма
рифма
строфа
жанр
колумб -путешественник = землетрясение-
первооткрыватель
образование гор
жертвы
природное явление
песня-композитор = самолет -
аэропорт
полет
конструктор
истребитель
слагаемое - сумма= множитель-
произведение
частное
разность
умножение

Читайте также

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

Укажите значения для переменных x и y после выполения операторов

x:=2;
у:=5;
х:=у;
у:=х;
2. Какую задачу решает данная программа?
program primer
var a,b,c: integer;
begin
writeln("введите двухзначное число ");
readln(a);
b:=a div 10 ;
c:=a mod 10;
write(c*10+b);
end.
а)находит сумму цифр числа;
б)вычесляет целую часть и остаток от деления числа на 10 ;
в)меняет цифры числа местами
г)находит цифры числа, а на экран выводит само число
3. Среди предложенных выражения выбирете логические :
а) (x=3)or (x<>4)
б)2*x+5;
в)x mod 2=0;
г)x div 3
д) x+у=10
е) х+у
ж)(х+у>5)or(x-у>5)
з)(х>3)and (х<=10)
4. Составьте условие для условного оператора в программе , которая выводит на экран приветствие в зависимости от времени суток . Пусть утро с8 до 12 ч, день с12 до 17 ч , вечер с 17 до 23ч, ночь-всё остальное время.
program primer;
begin
writeln("Который час?");
readln(x);
if__________then writeln('Доброе утро!');if__________then writeln('Добрый день!');
if__________then writeln('Добрый вечер!');
if__________then writeln('Доброй ночи!");
if__________then writeln('Введите число выходит за рамки интервала [0,24]');



Вы находитесь на странице вопроса "Доброго времени суток, уважаемые пользователи сайта. Прошу вас помочь с крайне сложным заданием на мое усмотрение, но за достойную награду. Прошу вас", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.