Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найти минимальный и максимальный элементы в матрице их номера.Формат вывода:

5-9 класс

Минимальный элемент A[3,4]=11
Максимальный элемент A[2,2]=89
Кумир!!!Полное решение!Заранее большое спасибо!! :3

Nicolay731 16 марта 2015 г., 3:17:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mari199824
16 марта 2015 г., 4:48:39 (9 лет назад)

Const n=10; m=10;
var a:array [1..n,1..m] of integer;
i,j,min,x1,y1,max,x2,y2:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write (a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
max:=a[1,1];
x1:=1;
x2:=1;
y1:=1;
y2:=1;
for i:=1 to n do
for j:=1 to n do
if a[i,j]<min then 
begin
min:=a[i,j];
x1:=i;
y1:=j;
end else 
if a[i,j]>max then begin 
max:=a[i,j];
x2:=i;
y2:=j;
end;
writeln ('Минимальный элемент    A[',x1,',',y1,']=',min);

Ответить

Другие вопросы из категории

Проследите, как изменяются числа в каждом ряду, и

продолжите каждый из рядов, вписав еще 4 числа.

в какой программе можно подставлять венки к фото?

хочу подготовить презентацию,но все картинки должны быть супер странными;) поэтому и интересуюсь;)

Читайте также

ПАСКАЛЬ! ПОМОГИТЕ, СРОЧНО!

Задать случайным образом 9 элементов числового массива – дробные числа от 10 до 50. В этом массиве:
1. Найти минимальный элемент и увеличить его на 100.
2. Найти максимальный элемент и поменять его местами с первым элементом.
3. Найти минимальный и максимальный элемент в числовом массиве из 10 элементов, заданных с клавиатуры. Поменять их местами.

Даю много баллов за решение!

написать программу по которой
найти минимальный и максимальный элемент массива и все элементы между ними заменить 0...(10,50)
Срочно

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами.

Выходные данные
Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "найти минимальный и максимальный элементы в матрице их номера.Формат вывода:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.