Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2

5-9 класс

Gerasimova20144 01 марта 2015 г., 13:52:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ДашаХомка
01 марта 2015 г., 15:12:21 (9 лет назад)

Var
a,b:Integer;
Begin
     Writeln('Введите число - '); Readln(a);
     if(a>0)  then b:=a*a else if (a<0) then b:=a*2;
     Writeln('Ответ: ',b);
End.

Ответить

Другие вопросы из категории

Читайте также

Pascal ABC

Задача 1
составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат .
Задача 2
составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

1)Определить, является ли числоа делителем числа b. Даны вещественные числа х и у, не равные друг другу. Меньшее из

этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.

2)Даны вещественные числа х и у, не равные друг другу. Меньшее из этих двух чисел заменить половиной их суммы, а большее — их удвоенным произведением.



Вы находитесь на странице вопроса "если введенное с клавиатуры число (не равное нулю) положительно вычислить его квадрат, а если отрицательно - умножить его на 2", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.