Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить программу вычисления значения функции с помощью разложения в ряд. В Паскале.

10-11 класс

SanyaManyanya 19 янв. 2016 г., 13:49:29 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Luda100
19 янв. 2016 г., 15:08:19 (8 лет назад)

Вот, написал. Но она выдает неверные результаты!!! Не пойму в чем причина, вроде бы все правильно составлено. Покажи преподу, может он подскажет
var
   s,y,e,x,nf:real;
   n:integer;
begin
write('Введите число x: ');
readln(x);
write('Введите точность вычислений: ');
readln(e);
nf:=1;
s:=1;
n:=1;
y:=1;
while abs(y)>=e do
  begin
  n:=n+1;
  nf:=(2*n-1)*(2*n-2)*nf;                         //здесь вычисляем факториал
  y:=power(-1,n+1)*power(x,2*n-1)/nf;
  if abs(y)>=e then s:=s+y
  end;
writeln('sin(',x,')=',s)
end.

Ответить

Другие вопросы из категории

перевести: число 91 из десятичной в двоичную число 1001110 из двоичной в десятичную число 17

десятичной в шестнадцатеричную

Из шестнадцатеричной в десятичную: В4

Исполнитель Чертежник имеет перо, которое можно поднимать, опускать и перемещать. При перемещении опущенного пера за ним остается след в виде прямой

линии. У исполнителя существуют следующие команды:
Сместиться на вектор (а, Ь) – исполнитель перемещается в точку, в которую можно попасть из данной, пройдя а единиц по горизонтали и b – по вертикали.
Запись: Повторить 5[ Команда 1 Команда 2] означает, что последовательность команд в квадратных скобках повторяется 5 раз.
Чертежник находится в начале координат. Чертежнику дан для исполнения следующий алгоритм:
Сместиться на вектор (5,2)
Сместиться на вектор (-3, 3)
Повторить 3[Сместиться на вектор (1,0)]
Сместиться на вектор (3, 1)
На каком расстоянии от начала координат будет находиться исполнитель Чертежник в результате выполнения данного алгоритма?
10

Помогите разобраться в задаче

const x:array [1..10] of integer=(-1,23,32,-8,27,-3,5,13,-4,17);
var i,k,s:integer; x1:array[1..10] of integer;
begin
for i:=1 to 10 do
x1[i]:=x[i];
begin
for k:=1 to 5 do
for i:=3 to 7 do if x[i]< x[i+1] then begin
S:=x1[i+1];
x1[i+1]:=x[i];
x1[i]:=s
end;
s:=x[6];
for i:=4 to 8 do s:=s+x[i] ;
writeln (s);
end;
end.

Ответ: 31. А именно, я не понимаю как именно идёт последовательность, знаю, что вложенный цикл повторяется пока не завершится, затем внешний пока не завершится. Но если оператор IF не выполняется, что следует? У меня именно в этом месте затуп. Буду признателен, если изложите по пунктам ход решения. спасибо!

Читайте также

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения

аргумента, вто¬рой — соответствующие значения функции: F(x)=xcos(1\x)+2 Решить нужно в паскаль.

Составить блок схему. Составить программу вычисления значений функции F(х) на отрезке [а;в] с шагом h. Результат представить в виде таблицы, первый

столбец которой - значения аргумента, второй - соответствующие значения функции.
F(x) =  \sqrt{x} ·  cos^{2} х.

Составить блок-схему и написать программу для решения задачи. Организовать вычисление значения функции y по формуле y=4x+3/x-1 -√2x+9 для любого заданного

значения аргумента x. Учесть вывод сообщения о невозможности вычисления значения функции



Вы находитесь на странице вопроса "Составить программу вычисления значения функции с помощью разложения в ряд. В Паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.