Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны три положительных числа. Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника (

10-11 класс

равносторонний, равнобедренный или разносторонний), иначе выдать соответсвующее сообщение.

Ilyuchenko78 12 дек. 2016 г., 14:16:34 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lika123456
12 дек. 2016 г., 15:18:55 (7 лет назад)

uses crt;
var a,b,c,mn,mx,sr,p,s:real;
begin
clrscr;
writeln('Введите 3 числа:');
readln(a,b,c);
if(a<=abs(b-c))or(a>=b+c)then
write('Это не треугольник!') else
 begin  
  mn:=a;
  if b<mn then mn:=b;
  if c<mn then mn:=c;
  mx:=a;
  if b>mx then mx:=b;
  if c>mx then mx:=c;
  sr:=a+b+c-mn-mx;
  if(a=b)and(b=c) then writeln('Это равносторонний треугольник')
  else if((a=b)and(b<>c))or((a=c)and(b<>c))or((b=c)and(a<>b))then
  writeln('Это равнобедренный треугольник')
  else writeln('Это разноcторонний треугольник');
  p:=(a+b+c)/2;  
  s:=sqrt(p*(p-a)*(p-b)*(p-c));
  writeln('его площадь=',s:0:2);
  write('Стороны в порядке убывания: ',mx:0:2,' ',sr:0:2,' ',mn:0:2);
 end;
readln
end.

Ответить

Другие вопросы из категории

какие из перечисленных ниже устройств входят в состав "минимальной конфигурации" компьютера?:

принтер, процессор, клавиатура, звуковая карта, монитор, оперативная память, устройство CD-ROM? Почему?
(на угад б я так смогла наставить, меня больше интересует вопрос "почему?" Не разочарует только полный ответ)

сравните 2Мбайт и 2056Кбайт
Известны длины сторон двух прямоугольников. Вычислить Площади прямоугольников и сравнить их .Определить,является ли прямоугольники квадратами. Выясни

ть поместится ли один прямоугольник внутрь другого. ( Программный код нужно писать в Паскале!)

Читайте также

Введите три числа.Если они могут быть длинами сторон остроугольного

треугольника,выведите их в порядке убывания и вычислите их площадь.

Введите три числа. Если они могут быть длинами сторон равнобедренного остроугольного....

Ребят,подскажите пожалуйста как проверить могут ли быть стороны длинами равнобедренного остроугольного треуг. Не могу понять ,как проверить именно на остроугольный треугольник ,в геометрии 0. Помогите пожалуйста

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.



Вы находитесь на странице вопроса "Даны три положительных числа. Если они могут быть длинами сторон остроугольного треугольника, то вычислить его площадь и определить вид треугольника (", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.