Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу заполнения массива из 10 элементов случайными числами и подсчитать произведение его элементов на языке Pascal

5-9 класс

Tatyanashkoda 08 июля 2015 г., 13:02:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kavetskaja04
08 июля 2015 г., 15:40:02 (8 лет назад)

Var s,i:integer;

r:array [1..10] of integer;

begin

s:=1;{Чтобы произведение не было равно 0, т.к. 0* на что то будет 0}

randomize;

for i:=1 to 10 do begin r[i]:=random(20); s:=s*r[i]; end;{Заполняем массив и сразу получаем во время заполнения произведение эелементов}

writeln(s);[Выводим значения произведения эелементов}

end.

Ответить

Другие вопросы из категории

Имеются пять карточек, на которых записана одна из букв: А, Б, Е, Ж, И. Надо составить последовательность из k карточек, соблюдая правила:1) любая

последовательность начинается буквой А;2) после гласной буквы не может снова идти гласная, а после согласной – согласная;3) буквы в последовательности не должны повторяться.В ответе укажите через пробел 3 числа - сколько последовательностей, удовлетворяющих правилам можно составить из 3-х, 4-х и 5-и карточек соответственно.

Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными

значениями.

Что тут не правильного?

Program zad2a;
Var a:array[1..10]of integer;
i:integer;
begin
for i:=1 to 10 do a[i]:=random(10)+1;
for i:=1 to 10 do begin
if a[i] mod 2 = 0 then
end;
writeln(a[i],' ');
end.

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте программу заполнения массива A(20) датчиком случайных чисел в диапазоне от -50 до 49 включительно.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

Помогите!!!

Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "Составить программу заполнения массива из 10 элементов случайными числами и подсчитать произведение его элементов на языке Pascal", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.