Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Здравствуйте! Помогите пожалуйста с программой.

10-11 класс

Описать функцию у=arcsin(x), cоставить программу решения уравнения sin(ax+b)=c (Паскаль)



2storyprops 11 апр. 2013 г., 19:22:04 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mother098
11 апр. 2013 г., 20:47:27 (11 лет назад)

Считаем, что в нашей реализации языка Pascal нет готовой функции для арксинуса и опишем арксинус на основе известного тригонометрического соотношения:
\arcsin(x)=\arctan(\frac{x}{\sqrt{1-x^2}})
Тогда
\sin(ax+b)=c; \ ax+b=\arcsin(c) \to x= \frac{\arcsin(c)-b}{a}
Область допустимых значений: |c|<1, a≠0

function arcsin(x: real): real;
begin
  arcsin := arctan(x / sqrt(1 - sqr(x)))
end;

var
  a, b, c, x: real;

begin
  Write('Введите через пробел значения a,b,c: ');
  Readln(a, b, c);
  if (c >= 1) then Writeln('Решения нет, c>=1')
  else if a = 0 then Writeln('Решения нет, a=0)')
  else Writeln('x=', arcsin(c) / sqrt(1 - sqr(x)):0:5)
end.

Тестовое решение:

Введите через пробел значения a,b,c: 3.25 -1.7 0.146
x=0.14652



Ответить

Другие вопросы из категории

народ помогите ответить на задание . В алгоритме, записанном ниже ,используется целочисленные переменные a и b .Определитель значение переменой a после

исполнении данного алгоритма:
a:=5
b:=a*2
b:=3*a-b
a:=(a+b)/5.
Ответ будет ? помогите пожл просто я заканчиваю 9класс и здаю инфо .

Нужно решение 2 задач Делфи

,Описати статичний масив.
Масив зчитується з текстового файлу.
Визначити:
Мінімальне значення масиву, його індекси

Задана матриця (n×m). Визначити номер рядка, середньоарифметичне елементів якої менше за середньоарифметичне попереднього рядка


2.Текстовий файл F1 має містити не менше 10 рядків.
Скопіювати з файлу F1 в файл F2 всі рядки, які не містять слова, яке починається за задану літеру. Визначте найкоротше слово у файлі F2.

Очень надо помогите пожалуйста.
4) Цепочка из трех бусин формируется по следующему правилу: На первом месте в цепочке стоит одна из бусин А, Б, В. На втором – одна из бусин Б, В, Г. На

третьем месте – одна из бусин А, В, Г, не стоящая в цепочке на первом или втором месте. Какая из следующих цепочек создана по этому правилу:
1) АГБ 2) ВАГ 3) БГГ 4) ББГ

Читайте также

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Здравствуйте! Помогите пожалуйста с программой.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.