Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дана последовательность целых чисел а1 а2....ан . найти два минимальных элемента последовательности количество чисел вводится с клавиатуры

10-11 класс

Tatjara83 11 янв. 2017 г., 1:17:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Polinasaranchin
11 янв. 2017 г., 2:21:12 (7 лет назад)

uses crt;
var a:array[1..100] of real;
i,n,ind:integer; min,min2:real;
begin
  clrscr;
  write('n='); read(n);
  writeln('massiv:');
  for i:=1 to n do
    read(a[i]);
  min:=a[1];
  min2:=a[1];
  for i:=1 to n do
    begin
      if a[i]<min then
      begin
        min:=a[i];
        ind:=i;
      end;
    end;
  for i:=1 to n do
    begin
      if (i<>ind) then if (a[i]<min2) then min2:=a[i];
    end;
  write(min,' ',min2);
end.

Ответить

Читайте также

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все

положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу



Вы находитесь на странице вопроса "дана последовательность целых чисел а1 а2....ан . найти два минимальных элемента последовательности количество чисел вводится с клавиатуры", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.