Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана последовательность целых чисел а1, а2, ..an. Образовать новую последовательность, выбросив из исходной те члены, которые равны min (а1, а2,

10-11 класс

..an).
Составила такую программу:

Orlovakatya72 04 сент. 2013 г., 20:10:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МайкВазовский
04 сент. 2013 г., 20:40:43 (10 лет назад)

Извините, но смысла в работе Вашей программы я не нашёл.
Я написал свой вариант, если не подходит - пишите.

Program I_have_got_name;
const n = 5;
var   mas:array[1..n] of integer; 
        i,min:integer;
 begin 
   min:=maxint; 
   writeln('Введите целые числа'); 
   for i := 1 to n do   
    begin     
     readln(mas[i]);   
     if mas[i]<min then min:=mas[i]; 
    end; 
   For i:= 1 to 5 do   
     If mas[i]<>min then write(mas[i],' ');
end.

Ответить

Другие вопросы из категории

в паскале abc помогите написать программу.

Дано натуральное число N. С клавиатуры вводятся N дат рождения в
формате DD.MM.YYYY (например, 17.04.2014). Напечатать название месяца, в
котором больше всего дней рождений. Если таких месяцев несколько, то
напечатать название самого позднего из них.

Читайте также

Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn..Все

положительные элементы уменьшить в 2 раза. Составить блок-схему алгоритма, написать программу



Вы находитесь на странице вопроса "Дана последовательность целых чисел а1, а2, ..an. Образовать новую последовательность, выбросив из исходной те члены, которые равны min (а1, а2,", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.