Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Дана строка символов, состоящая только из цифр. Определить, сколько раз среди них встречается цифра 5.

10-11 класс

Jendos 24 янв. 2015 г., 18:00:11 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vova116
24 янв. 2015 г., 19:50:43 (9 лет назад)

var s: string; i,k: integer;
Begin
k:=0;
Read(s);
for i:=1 to length(s) do
If s[i]='5' then k:=k+1;
Writeln (k);
End.

Ответить

Другие вопросы из категории

Составить программу, по которой выведется значение true, если точка с заданными координатами (x,y)

лежит внутри заштрихованной области и false

Срочно! Ответьте, пожалуйста!!!

При использовании CASE-технологии разработки программного продукта основные усилия программист затрачивает на:
(укажите, пожалуйста, несколько вариантов ответа)


1. Кодирование

2. Анализ

3. Проектирование

4. Отладка

5. Тестирование

напишите пожалуйста программу с case
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.

Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

Читайте также

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

дана строка символов

Сколько раз среди данных символов встречаться цифра?
паскаль. подскажите



Вы находитесь на странице вопроса "Дана строка символов, состоящая только из цифр. Определить, сколько раз среди них встречается цифра 5.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.