Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

На плоскости на расстоянии s [1], s [2],..., s [10] от центра кругового кольца с внутренним радиусом r и внешним R расположены точки. Определить

10-11 класс

количество точек, расположенных внутри кольца. ч/з турбо паскаль(одномерный массив). Помогите плз.

Teyder 24 дек. 2013 г., 22:12:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Smaris
24 дек. 2013 г., 23:27:14 (10 лет назад)

если правильно понял

program k,i,r1,R2:integer;

                 s:array[1..10] of integer;

begin;

k:=0;

readln(r1);

readln(r2);

for i:=1 to 10 do read(a[i]);

for i:=1 to 10 do

if (a[i]>r1) and (a<r2) then inc(k)

write(k);

Ответить

Другие вопросы из категории

Ребята,помогите добавить цикл.который будет генерировать случайные числа,с помощью команды srand.

Эта программа определяет,возрастающая или убывающая последовательность чисел.

если возрастает,например 1234(1 < 2 < 3 <4 )-то пишет 1
если убывает 321 или 231(3 < 2 < 1)-ложь,пишет ноль
если 111(1 < 1 < 1)ложь,тк строгая возрастающая последовательность,пишет ноль


#include <iostream>
int main()
{
int n;
bool flag = true;
std::cin >> n;
while(n != 0)
{
while (n >= 10)
{
if(n / 10 % 10 >= n % 10)
flag = false;
n = n / 10;
}
std::cout << flag << std::endl;
flag = true;
std::cin >> n;
}
}

Читайте также

алгоритм Мишень цел n, k, i вещ массив P[1000] вещ r1, r2 начало ввести

n, массив P и радиусы r1, r2 /* Исходные данные */

вывести заголовок задачи и значения n, P, r1, r2 k ¬0 для i от 1 до n шаг 1 выполнять/*

Подсчитать число точек */ если r1 < ri и ri < r2 то k ¬k +1

конец-если

конец-цикл

вывести заголовки выходных данных и значений k конец

Теперь спланируем тестирование.

Проверку программы выполним при следующих исходных данных.

Зададим число точек на плоскости: n = 10. Подберем расстояния и радиусы: 0.03 21.0 12.89 7.41 99.99

P = 12.34 56.78 90.98 7.6 0.54

r1 = 12.35 r2 = 56.90.

Выходные данные в этой задаче будут иметь вид: Мишень Исходные данные:

n= 10 Массив P[n]: 0.03 21.0 12.89 7.41 99.99 12.34 56.78 90.98 7.6 0.54 r1 = 12.35 r2 = 56.90

Ответ: внутри 3 точки (три точки находятся внутри кольца).помогите написать программа в паскале и алгоритм блок-схему.пожалуйста срочно!

Дано множество точек с координатами на плоскости.

Написать программу, которая использует подпрограммы и выведит на экран наименьшее расстояние между двумя точками.

Решите головоломку.Если в слове А его вторую половину, буквы которой образуют слово В, заменить на слово С, то получится слово Д. Причем: А - фрагмент

оперативной памяти размером в 16 байтов; В – конечное число точек на плоскости, соединённых отрезками кривых линий; С – единица измерения расстояния; Д – аргумент или результат процедуры.В ответе запишите найденные слова: сначала А, затем, В, С и Д, через один пробел, без знаков препинания.

Даны координаты трех точек на плоскости:

A(-12,57;-10,23),B(3,3;12,47),C(15,67;-10,32).Найдите с точностью до одного знака после запятой площадь треугольника АВС. В ответе укажите только число,отделяя дробную часть от целой запятой без пробелов,например,13,2

Код программы "Тест" на Pascal

Необходимо написать код программы в формате .txt , чтобы на экране выводилось следующее:

1. Выводится текст "Вам предлагается тест на тему "Поведение в кабинете информатики""

2. Выводится вопрос и несколько вариантов ответа.

3. Выводится "Выберите № ответа".

4. Вопросов всего 3.

5. Выводится "Тест окончен".

6. Выводится "Оценка: Зачет" или "Оценка: Незачет"

Вот сами вопросы:
1. На каком расстоянии от монитора должен
работать ученик за компьютером?

a) 15-20 см

b) 50-70 см

c) Меньше 40 см
d) 90-110 см
2. Можно ли класть тетради, книги, диски на
монитор и клавиатуру?

a) Можно.

b) Можно только на клавиатуру.

c) Можно только на монитор.

d) Нельзя.
3. При появлении запаха гари нужно…

a) Бежать за водой, чтобы предотвратить
дальнейшее возгорание.

b) Прекратить работу, сообщить
преподавателю
c) Не обращать внимания
d) Быстро убежать из кабинета



Вы находитесь на странице вопроса "На плоскости на расстоянии s [1], s [2],..., s [10] от центра кругового кольца с внутренним радиусом r и внешним R расположены точки. Определить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.