Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задача по информатике 9 класс масивы. Нужно самый маленький элемент поставить на первое место, а самый болшой на последнее

10-11 класс

Shashaevdania 25 дек. 2013 г., 15:21:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Storojuk
25 дек. 2013 г., 18:14:04 (10 лет назад)

Program enot;
Var a: array [1..5] of integer;
i,min,max,b,j,g,h,f,c:integer;
begin
for i:= 1 to 5 do read (a[i]);
min:=a[1];
for i:= 2 to 5 do
if a[i]<min then
 begin 
min:= a[i];
j:= i;
end;
max:= a[1];
for i:= 2 to 5 do
if a[i]>max then
 begin
max:= a[i];
h:=i;
end;
f:=a[j];
a[j]:=a[1];
a[1]:=f;
g:= a[h];
a[h]:=a[5];
a[5]:= g;
for i:= 1 to 5 do
write(a[i]:4);
end.

+ 0 -
Arsenjteva
25 дек. 2013 г., 20:19:25 (10 лет назад)

из сколька элементов массив? заполнять рандомно или с клавиатуры?

+ 0 -
Aivish
25 дек. 2013 г., 22:29:58 (10 лет назад)

с клавы

Ответить

Другие вопросы из категории

Помогите, пожалуйста! Мне надо подробное решение.

На вход программе подается
последовательность символов, заканчивающаяся точкой. Требуется написать
программу, которая определяет, есть ли в этой последовательности десятичные
цифры, и выводит наибольшее число, которое можно составить из этих цифр.
Ведущих нулей в числе быть не должно (за исключением числа 0, запись которого
содержит ровно одну цифру). Если цифр нет, программа должна вывести на экран
слово «Нет», а если есть – слово «Да» и в следующей строчке искомое число.
Например, если исходная последовательность была такая:

Day 10, mice 8: "Year" 7 is a mistake 91.

Читайте также

Задача 1 Составить программу При поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . В

массиве A[n] записаны оценки экзаменующихся , полученные на первом экзамене . Подсчитать , сколько человек не допущено ко второму экзамену .

Задача 2

В одномерном массиве , состоящем из n вещественных элементов , вычислить ;

1) минимальный элемент массива;

2)сумму элементов массива , расположенных между первым и последним положительными элементами .

Преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

Помогите пожалуйста решить задачу по информатике за 3 класс. Утро. Все цветки на клумбе-часах открыты 4, 5, 6, 7, 8, 9 а) Отметь истинные высказывания

t >= 6 t= 9 t >= 10 t < 10 t>= 6 И t<10 t< 4 И t<10 t<4 ИЛИ t<10 б) Обведи столбик с простыми высказываниями

задание по информатике 2 класс

ИРА , БОРЯ И АЛЁША ЗАКОДИРОВАЛИ ПО
ОДНОМУ СЛОВУ .ВОТ ИХ КОДЫ: ПЕРВОЕ СЛОВО 10111111 10111110 10111011
10110101, ВТОРОЕ СЛОВО 10111110 10110111 10110101 11000000
10111110,третье слово10111011 10110101 11000001.
ПОМОГИТЕ ПОЖАЛУЙСТА.



Вы находитесь на странице вопроса "Задача по информатике 9 класс масивы. Нужно самый маленький элемент поставить на первое место, а самый болшой на последнее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.