Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Заданы два натуральных

5-9 класс

числа. Определить, является ли среднее
арифметическое этих чисел целым числом.
решить задачу в паскале.

Smshapovalova 17 мая 2014 г., 19:24:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yliahka1999
17 мая 2014 г., 21:39:27 (9 лет назад)

var a,b:real;
begin
writeln('Vvedite a');read(a);
writeln('Vvedite b');read(b);
if (frac((a+b)/2)=0) then writeln('Da') else writeln('Net');
end.

p.s функция frac возвращает дробную часть числа.

Ответить

Другие вопросы из категории

Построение алгоритма и его реализация в среде Visual Basic для следующей задачи: Ученик выполнил работу. В зависимости от количества ошибок в работе

ученика необходимо выставить соответствующую отметку за работу. При выставлении отметки учитель пользуется следующими значениями – при отсутствии ошибок оценка 5, при одной ошибке - 4, при 2 ошибках – 3, при 3 и более ошибках – 2.

Читайте также

Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B.

Формат входных данных
Первая строка входного файла содержит два целых числа A и B (1 <= A, B <= 10^9).
Формат выходных данных
Выведите ответ к задаче.

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10

СРОЧНООООООООООООООООО!!!!!!!!!!

Напишите эффективную программу, которая по двум натуральным числам а и b, не превосходящим 30 000, подсчитывает количество натуральных чисел, кратных 3, на отрезке [а, b] (включая концы отрезка). Программа получает на вход два натуральных числа а и b, при этом гарантируется, что 1 а b 30 000. Проверять входные данные на корректность не нужно. Программа должна вывести одно число: количество натуральных чисел, кратных 3, на отрезке [а, b].

Pascal а)Для заданных целых чисел A и B вывести двучлен Ax+B в корректном виде. Для A, B=0 результатом должен быть 0.

Формат файла входных данных:

Во входном файле заданы два целых числа не превосходящих 32000.


Формат файла выходных данных:

Вывести математически корректное выражение.

б)Самолет взлетает в X (целое, 0<=X<=23) часов по местному времени в часовом поясе номер M (целое, 0<=M<=23). После полета в течение K (целое, 1<=K<=12) часов он приземляется в часовом поясе номер N (целое, 0<=N<=23). Определите местное время в пункте приземления. Считать, что часовые пояса нумеруются с запада на восток.



Формат входных данных:

В первой строке текстового файла через пробел записаны числа X, M, K, N.


Формат выходных данных:

В выходной файл требуется выдать местное время в пункте назначения в часах.

Пример входного файла
20 1 4 1

Пример выходного файла
0

Помогите буду благодарен.

Ограничения [Время: 1000ms, Память: 128MB, Сложность: 2%]

Задана продолжительность некоторого события в секундах целым числом. Считая, что в одном часе 60 минут, а в минуте 60 секунд, определить продолжительность события в часах, минутах и секундах.
Входные данные:
Во входном потоке задано единственное натуральное число T (T < 10000000)

Выходные данные:
Вывести три натуральных числа через пробел: часов, минут, секунд

Пример входного файла (input.txt):
3666



Вы находитесь на странице вопроса "Заданы два натуральных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.