Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг.

10-11 класс

Twinkleee 22 июня 2014 г., 17:05:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Geinlad16
22 июня 2014 г., 18:27:20 (9 лет назад)

const n=50;
var
a:array[1..n] of integer;
m,i,j:integer;
begin
randomize;
for i:=1 to n do begin
a[i]:=random(3600)+300;
write(i,'. ',a[i]);
end;
for j:=1 to n-1 do begin
for i:=1 to n-1 do
if a[i]>a[i+1] then begin
m:=a[i];
a[i]:=a[i+1];
a[i+1]:=m;
end;
end;
writeln;
for i:=1 to 10 do writeln(i,') ',a[i]);
end.

То-что курсивом это организация ввода в массив цен. Если у вас другой способ то измените. 3600 это max цена, а 300 min можно и тут поменять . Как угодно)

Ответить

Другие вопросы из категории

паскаль

данн предложение. все его символы , стоящие на третьем, шестом, девятом и т.д местах , заменить на буквы "а"

гибкий магнитный диск
Решите пожалуйста,очень нужно! С клавиатуры вводят слово и символ. Составьте программу,которая:а)проверяет,есть ли в этом слове заданный

символ;б)определяет позицию заданного слова;в)подсчитывает количество вхождений заданного символа.

Читайте также

1)ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива

2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Помогите пожааалуйста,вообще нереально сделать(задачи зависят друг от друга) 1.заполнить массив из 100 элементов случайными числами.вывести на

экран с 20 по 50 в строку через пробел

2.для первыз десяти элементов найти среднее арифмитическое

3.вывести на экран только четные элементы с 1 по 10 элементы массива

4.найти сумму нечетныз значений с 20 по 50 элемент

5.найти количество элементов кратныз заданному числу,введёного с клавиатуры среди всез элементок линейного массива



Вы находитесь на странице вопроса "В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.