Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано натуральное число N. Выбросить из записи все чётные числа. Например:Дано:34271 Получили:371

5-9 класс

Daska2001 15 июля 2016 г., 19:02:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
MadSerega
15 июля 2016 г., 21:45:46 (7 лет назад)

var n,i,l:integer;

res:real;

Begin

  read(n);

  while n>0 do begin

    i:=n mod 10;

    n:=n div 10;

    if i mod 2 <> 0 then begin

      res:=res+i*exp(l*ln(10));

      l:=l+1;

    end;   

  end;

  writeln(res);

End.

Ответить

Другие вопросы из категории

Помогите пожалуйста написать прогу, заранее спасибо)

Заполните массив случайными числами от 0 до 4(вывести его на экран) и выведите на экран номера тех элементов, значения которых равны х(х вводится с клавы)

как человек хранит информацию????

какими свойствами обладает память человека??
чем отличается память человека от памяти человечества????
как люди хранят информацию различных видов?приведите примеры?

Между командами ввода и вывода впишите в алгоритм несколько команд присваивания, в результате чего должен получиться алгоритм возведения в 4-ю с

тепень введенного числа(дополнительные переменные, кроме А,не использовать.

Ввод А

Вывод А

Читайте также

1)найти количесво делителей натурального числа,сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа

верно ли,что первая цыфраа данного числа чётная?

3)найти все трёхзначные числа,которые состоят из разных цыфр,а их сумма равна А(А вводится с клавиатуры)

4)найти все симметричные натуральные числа(палиндромаиз промежутка от А до В(А и В вводится с клавиатуры)

дано натуральное число N, Написать ему выводящую на экран последовательность натуральность натуральных чисел от 1 до N, задание 2 дано натуральное число

N, Написать ему выводящую на экран последовательность натуральность натуральных чисел отN до 1, номер 3 Даны натуральные числа N и К.Написать программу выводящую на экран последовательность из N чисел , каждое из которых равно К хотя бы что нибудь решите помогите очень надо!!!!!!!!!

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "Дано натуральное число N. Выбросить из записи все чётные числа. Например:Дано:34271 Получили:371", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.