Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

2. Даны натуральные числа от 35 до 87. Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

5-9 класс

Arishkeevich1997 28 апр. 2013 г., 3:48:03 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yki24
28 апр. 2013 г., 4:39:32 (11 лет назад)

program 1;

var i:integer;

begin

for i:=35 to 87 do

if ( i mod 7=1) or (i mod 7=2) or ( i mod 7=5)  then write (i)

end.

+ 0 -
Beey
28 апр. 2013 г., 6:21:21 (11 лет назад)

var
a: array[1..53] of integer;
i, n: byte;
begin
n:=34;
write('Числа: ');
for i:=1 to 53 do
begin
n:=n+1;
a[i]:=n;
write(a[i]:3);
end;
writeln;
writeln('При делении на 7 дают остаток 1, 2 или 5: ');
for i:=1 to 53 do
begin
if (a[i] mod 7 = 1) or (a[i] mod 7 = 2) or (a[i] mod 7 = 5)
then begin
if a[i] mod 7 = 1 then writeln(a[i], ' (остаток 1)');
if a[i] mod 7 = 2 then writeln(a[i], ' (остаток 2)');
if a[i] mod 7 = 5 then writeln(a[i], ' (остаток 5)');
end;
end;
end.

Ответить

Другие вопросы из категории

ПРОШУ,ПОМОГИТЕ!!!умоляю!БУДЬТЕ ДОБРЫ!!

Например:
Rectangle(50,50,250,150). не могу понять как находят то что в скобках (50,50,250,150).как???скажите те кто знает, очень прошу!

помогите срочно!!!!!

Читайте также

Вариант № 2 1)Подсчитать сумму квадратов всех отрицательных и четных чисел из 10 вводимых. 2) Даны натуральные числа от 35 до 87.

Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.

3)Дано целое число а и натуральное (целое неотрицательное) число n. Вычислить а в степени n, используя в программе лишь операцию умножения.

4)Введите последовательность из n целых чисел. Найти наибольшее из всех отрицательных чисел. Вывести его значение и порядковый номер.

5)Вычислите: 99-97+95-93+91-89+....+7-5+3-1.

6)Доказать (путем перебора возможных значений), что для любых величин А, В, С типа Boolean следующая пара логических выражений имеет одинаковые значения (эквивалентны): A OR (B AND C) и (A OR B) AND (A OR C).

1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму

двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?



Вы находитесь на странице вопроса "2. Даны натуральные числа от 35 до 87. Найти и напечатать те из них, которые при делении на 7 дают остаток 1, 2 или 5.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.