Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ввести несколько чисел, определить каких чисел больше - положительных или отрицательных

5-9 класс

ТИХАН126 05 июля 2013 г., 4:13:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cake353
05 июля 2013 г., 6:03:45 (10 лет назад)

например: 22, 4, 5, 8, 6, 13, 654...-2, -54, -212, -51, -9...

положительных: 7

отрицательных: 5

ответ: положительных чисел больше чем отрицательных (7>5)

просто любые числа возьми и потом посчитай их....или там уже даны числа?

+ 0 -
Schweppes21
05 июля 2013 г., 6:54:54 (10 лет назад)

var

  countp, countm : integer;

  tmp : real;

begin

  countp := 0;

  countm := 0;

  while not eoln do

  begin

    read (tmp);

    if tmp >0 then inc (countp)

    else if tmp < 0 then inc (countm);

  end;

  if countp > countm then writeln ('Положительных')

  else if countp < countm then writeln ('Отрицательных')

  else writeln ('Равно');

end.

Ответить

Другие вопросы из категории

помогите создать программу по задаче:

шкаф:a,b,c
дверь:x,y
Можно ли пронести шкаф в дверь??

В таблице приведены запросы и ко-во найденных по ним страниц некоторого сегмента сети Интернет.

Запрос Найдено стр.(в тысячах)
ШОКОЛАД l ЗЕФИР 15 000
ШОКОЛАД & ЗЕФИР 8 000
ЗЕФИР 12 000
Какое количество страниц (в тысячах) будет найдено по запросу шоколад?

2) Все ученики, которые учатся в первую смену, приходят в школу в 8 часов.Серёжа учится в первую смену.Когда приходит Серёжа в школу?

3) Названия городов-имена собственные.Имена собственные пишутся с большой буквы.Значит,........
4) Если числитель дроби меньше знаменателя, то дробь правильная. У дроби 3/8 числитель меньше знаменателя. Следовательно,................
5) Все растения на свету поглощают углекислый газ.Тополь-растение.Следовательно,...........

запишите число 2010,0102(десятичная система) пятью различными способами в нормальной форме.

запишите следующие числа в нормальной форме с нормальной мантиссой - правильной дробью, имеющей после запятой цифру, отличную от нуля:
а) 217,934(десятичная система);
б) 75321(десятичная система);
в)0,00101(десятичная система).

Читайте также

1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите

программу определяющую каких элементов в точке больше положительных или отрицательных

Задача по паскалю тип integer

каких элементов в массиве больше положительных или отрицательных

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "ввести несколько чисел, определить каких чисел больше - положительных или отрицательных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.