Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В управляющий совет школы входят родители, учителя и учащиеся школы, причем родителей должно бфть не менее одной трети от общего числа членов совета. В

10-11 класс

настоящий момент в совет входит N чесовек, из них К родителей. Определите, сколько родителей нужно дополнительно ввести в совет, чтобы их число стало составлять не менее трети от числа членов совета.

Программа получает на вход два целых числа N и К (N>0, 0<=K<=N), записанные в отдельных строках, - текущее число члено совета и числао родителей в совете.

Программа должна вывести единственное число - минимальное число родителей, которое необходимо ввести в совет.

Aslan2699 23 окт. 2013 г., 6:26:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Тарпеда1995
23 окт. 2013 г., 8:08:24 (10 лет назад)

var n, k: integer;
begin
   readln(n, k);
   if k mod 3=0 then writeln(k div 3 - n)
                      else writeln(k div 3 + 1 - n);
end.

+ 0 -
Lelya0879
23 окт. 2013 г., 10:06:47 (10 лет назад)

var k,n,a:integer;
begin
  readln(n, k);
  a:=k;
  while k<(n/3) do     
begin   
 k:=k+1; 
   n:=n+1;     
end;     
writeln(k-a);
end.

Надеюсь на Лучший ответ

Ответить

Другие вопросы из категории

1.

Дан
одномерный массив а(n), в кото­ром находится единственный эле­мент ,значение
которого принадлежит интервалу от 2 до 5. Найти где он нахо­дится , и
упорядочить по убыванию эле­менты, расположенные перед ним. Вы­дать на экран
номер элемента и упорядо­ченный массив.

Найдите в литературе или в Интернете характеристики современных микропроцессоров,устройств статической и динамической памяти,внешних запоминающих

устройств,устройств отображения информации (вывода) и сравните их с аналогичными характеристиками устройств первых ЭВМ.

выполнить преобразование шестнадцатеричного числа в двоичное

каждую 16ю цифру представить соответствующими четырьмя двоичными цифрами
2АЕ9 и 22В1

Укажите минимальный объем памяти (в килобайтах), достаточный для хранения любого растрового изображения размером 256x256 пикселей, если известно, что в

изображении используется палитра из 216 цветов. Саму палитру хранить не нужно.

Читайте также

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.

Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

Помогите написать прогу на Паскале!Пожалуйста! Занятия в начальных классах отменяются в тех

случаях, когда температура воздуха не выше –25 градусов, а также при ветре не менее 7 м/с и температуре воздуха не выше –20 градусов. По утренней сводке погоды определить, пойдут ли дети в школу.

решите задачки пожалуйста ( задачки должны быть на цикл while) 1. Вклад в банке составляет x рублей. Ежегодно он увеличивается

на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.

Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

2. Дано натуральное число

Автомат

получает на вход два двузначных шестнадцатеричных числа. В этих числах все
цифры не превосходят цифру 6 (если в числе есть цифра больше 6, автомат
отказывается работать). По этим числам строится новое шестнадцатеричное число
по следующим правилам.

1.
Вычисляются два шестнадцатеричных числа – сумма старших разрядов полученных
чисел и сумма младших разрядов этих чисел.

2.
Полученные два шестнадцатеричных числа записываются друг за другом в порядке
возрастания (без разделителей).

Пример.
Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A.

Определите,
какое из предложенных чисел может быть результатом работы автомата.

1) 9F 2) 911 3) 42



Вы находитесь на странице вопроса "В управляющий совет школы входят родители, учителя и учащиеся школы, причем родителей должно бфть не менее одной трети от общего числа членов совета. В", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.