Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сколько нечетных среди n введенных причем надо вводить эти числа с клавиатуры n раз

5-9 класс

Deda123912 05 окт. 2015 г., 5:28:49 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Deryusheva
05 окт. 2015 г., 6:29:50 (8 лет назад)

begin
write('Введите n: ');
  var n := ReadInteger;
var c := 0;
for var i:=1 to n do
begin
write ('Введите целое число: ');
var x := ReadInteger;
if x mod 2 <> 0 then
c += 1;
  end;
writeln('Количество нечетных равно ', c);
end.

Ответить

Другие вопросы из категории

вид списка в компе 14 букв
что можно отнести к достоинствам векторной графики по сравнению с растровой:

1 малый объем графических файлов
2 фотографическое качество изображения
3 возможность просмотра изображения на экране графического дисплея
4 высокое качество печати изображения на принтере
5 возможность поточечного редактирования изображения

Читайте также

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

1.С клавиатуры вводится действительное число a.Найти его квадратный корень.

2.С клавиатуры вводится действительное число p.Записать отдельно его целую часть C.
Помогите составить программу.

Помогите очень срочно! 315. По данному натуральному n вычислите сумму 1^2 + 2^2+...+n^2. Вводится единственное число n. Необходимо вывести вычисленную

сумму. 346.Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел. 347.Вводится число N, а затем N чисел. Выведите YES, если среди введенных чисел есть хотя бы один нуль, или NO в противном случае.

С клавиатуры вводятся 3 числа, подсчитать сколько среди них четных положительных чисел.

PS: использовать функцию деления по модулю:
a mod b- выдает остаток при делении числа а на число b
15 mod 2=1
15 mod 3=0



Вы находитесь на странице вопроса "Сколько нечетных среди n введенных причем надо вводить эти числа с клавиатуры n раз", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.