Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найдите среднее арифмитическое минимального и максимального элемента из 10 вводимых. что не так?? Program Ex1;

10-11 класс

var i,max,min,x,:integer;
Sr:real;
begin
for i := 1 to 10 do
begin
writeln('вв-те ',i,' число' );
readln(x);
End;
if x<min then
min:=x;

if x>max then
max:=x;
sr:=(max+min)/2;
Writeln(max);
Writeln(min);
Writeln(Sr);
Readln;
end.

AnastaciaMiller 09 дек. 2013 г., 11:55:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Masteryakrut
09 дек. 2013 г., 14:11:54 (10 лет назад)

Если ты в 10-11, то необходимо с массивом:
const n=10;
var a:array[1..n] of integer;   
     i,min,max:integer;   
     sum:real;
begin
for i:=1 to n do readln(a[i]);
min:=a[1]; 
max:=a[1];
for i:=1 to n do begin
if a[i]>max then max:=a[i];
if a[i]<min then min:=a[i];
end;
sum:=(min+max)/2;
writeln(sum);
end.


Без массива:
uses crt;
const n=10;
var  x,i,min,max:integer;
     sum:real;
begin
min:=10000;
max:=-10000;
for i:=1 to n do begin
readln(x);
if x>max then max:=x;
if x<min then min:=x;
end;
sum:=(min+max)/2;
writeln(sum);
end.

+ 0 -
Polina1234567890qwer
09 дек. 2013 г., 16:54:19 (10 лет назад)

но все же спасибо))

+ 0 -
Zarinka2808
09 дек. 2013 г., 19:02:47 (10 лет назад)

Добавил без массива.

+ 0 -
Irkin8282
09 дек. 2013 г., 20:09:45 (10 лет назад)

Хотя нет, без массива бред получается...

+ 0 -
Hhshissi
09 дек. 2013 г., 22:40:59 (10 лет назад)

Обновил, теперь не бред) Работает безмассива)

+ 0 -
Yanka173
10 дек. 2013 г., 0:56:25 (10 лет назад)

ну я немного по-другому исправила)) тоже работает, спасибо еще раз))

Ответить

Другие вопросы из категории

Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.

Program test;
uses crt;
Const
N=5;
var a : array [1..N] of integer;
var i , Max , k , t , f : integer;
begin
For i:=1 to N do
A[i]:=random(8);
write ('Массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
writeln;
For i:=1 to (N-1) do
begin
Max:=A[i];
For k:=i+1 to N do
If (A[k]>Max) then
begin
Max:=A[k];
f:=k;
end;
t:=A[i];
A[i]:=A[f];
A[f]:=t;
end;
write ('Упорядоченный массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
end.

Читайте также

ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность

максимального и минимального

в) максимальный элемент из стоящих на четных местах

г) сумму положительных и среднее арифметическое отрицательных

д) второй максимум

е) длину наибольшего фрагмента, состоящего из одинаковых элементов.

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать



Вы находитесь на странице вопроса "найдите среднее арифмитическое минимального и максимального элемента из 10 вводимых. что не так?? Program Ex1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.