Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Привет!Очень срочно!!!Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: S=pi *R^2

10-11 класс

Senunmadara1 02 июля 2013 г., 1:56:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chistovdanila
02 июля 2013 г., 2:31:11 (10 лет назад)

procedure MinMax(var min, max: real);
var
  a: real;
begin
  if (min > max) then
  begin
    a := min;
    min := max;
    max := a;
  end;
end;

var
  r1, r2: real;
begin
  readln(r1, r2);
  r1 := pi * sqr(r1);
  r2 := pi * sqr(r2);
  MinMax(r1, r2);
  writeln('S = ', r2 - r1);
end.

Ответить

Другие вопросы из категории

обчислення суми чисел які діляться на 3
Умоляю, помогите с Паскалем

1. Пользователь вводит неотрицательное однозначное число A. Написать программу:
вычисляющую в случае ввода 1 - площадь круга с радиусом A,
вычисляющую в случае ввода 2 - площадь квадрата со стороной A,
вычисляющую в случае ввода 3 - площадь равностороннего треугольника со стороной A,
выдающую сообщение «нужно ввести число 1, 2, 3» в остальных случаях.

Проектная организации решила создать электронный архив

проектов различных домов. Было решено начать работу с эскизов
домов, нарисованных на чертежной бумаге формата A1 (594 × 841 мм).
После оцифровки каждого эскиза получили файлы изображений в
формате .bmp. Выбери знак, устанавливающий отношение между
размерами файлов.
1) 1 > 2; 2) 1< 2; 3) 1 = 2; 4) Размеры файлов
невозможно сравнить.

Читайте также

Написать программу на языке Паскаль для вычисления значений функции y (см. для своего варианта) на интервале [a,b] с шагом h. Значения a,b и h ввести с

клавиатуры. На экран вывести результат вычислений в виде таблицы. 1 Блок-схема алгоритма программы, выполненная с использованием графических средств редактора WORD; 2 Текст программы; 3 Результаты выполнения (копия экрана). (3x+2)^2- sqrt3x/(3x)^2 a 5;b 7; h 0,1

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





срочно!

написать программу и блок схему



Вы находитесь на странице вопроса "Привет!Очень срочно!!!Написать программу и блок -схему для вычисления площади кольца, используя подпрограмму нахождения площади круга: S=pi *R^2", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.