Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Тема: условный оператор.

5-9 класс

Имеется стол прямоугольной формы размером axb (a и b - целые числа, a>b). В каком случае на столе можно разместить большее количество картонных прямоугольников с размерами czd (c и d - целые числа, c>d): при размещении их длинной стороной вдоль длинной стороны стола или вдоль короткой. Прямоугольники не должны лежать один на другом и не должны свисать со стола.

танюша1600 25 марта 2017 г., 19:27:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5470
25 марта 2017 г., 20:19:33 (7 лет назад)

program pram;
var  a,b,bol,men,pro,bol1,men1,c,v:integer;
begin 
writeln('Ââåäèòå 2 ñòîðîíû ñòîëà');
readln(a,b);
if (a > b) then  begin 
bol := a ; 
 men := b ; 
 end   
else 
  begin   
 bol := b; 
   men := a;   
 end;
writeln('Ââåäèòå 2 ñòîðîíû êàðòîííûõ ïðÿìîóãîëüíèêîâ');
readln(c,v);
if (c > v) then  begin  bol1 := c ;
  men1 := v ; 
 end   
else 
   begin    bol1 := v;   
 men1 := c;   
end;
c := bol div bol1;
v := men div men1;
pro := c * v;
writeln('Êàðòî÷åê íà ñòîëå ',pro);
readln;
end.

Ответить

Другие вопросы из категории

30 элементов от -400 до 400

написать программу которая подсчитывает среднее арифметическое отрицательных элементов (это в паскаль программ константа и т.д) Пожалуйста напишите

Читайте также

Дан условный оператор:

if a<5 then c:=1

else if a>5 then c:=2
else c:=3

какое значение имеет переменная a, если в результате выполнения условного оператора переменной c присваиваетсязначение 3?

Дан условный оператор:

if a<5 then c:=1
else if a>5 then c:=2
else c:=3
Какое значение имеет переменная a , если в результате выполнения условного оператора переменной c присваивается значение 3?

Укажите значения для переменных x и y после выполения операторов

x:=2;
у:=5;
х:=у;
у:=х;
2. Какую задачу решает данная программа?
program primer
var a,b,c: integer;
begin
writeln("введите двухзначное число ");
readln(a);
b:=a div 10 ;
c:=a mod 10;
write(c*10+b);
end.
а)находит сумму цифр числа;
б)вычесляет целую часть и остаток от деления числа на 10 ;
в)меняет цифры числа местами
г)находит цифры числа, а на экран выводит само число
3. Среди предложенных выражения выбирете логические :
а) (x=3)or (x<>4)
б)2*x+5;
в)x mod 2=0;
г)x div 3
д) x+у=10
е) х+у
ж)(х+у>5)or(x-у>5)
з)(х>3)and (х<=10)
4. Составьте условие для условного оператора в программе , которая выводит на экран приветствие в зависимости от времени суток . Пусть утро с8 до 12 ч, день с12 до 17 ч , вечер с 17 до 23ч, ночь-всё остальное время.
program primer;
begin
writeln("Который час?");
readln(x);
if__________then writeln('Доброе утро!');if__________then writeln('Добрый день!');
if__________then writeln('Добрый вечер!');
if__________then writeln('Доброй ночи!");
if__________then writeln('Введите число выходит за рамки интервала [0,24]');

работа по программированию: "Условный оператор"

Составить блок-схему и программу к задаче:
В компьютер вводят два целых числа. Если а больше b, то вывести сообщение "Наибольшее число="; а иначе вывести сообщение "Наибольшее число="; b

1. Как выглядит структура программы на паскаль?

2. Что такое оператор присваивания?
3. По каким правилам определяется порядок выполнения операций в арифметическом выражении?
4. Полная и неполная форма условного оператора?



Вы находитесь на странице вопроса "Тема: условный оператор.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.