Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Изобразить лестницу из N одинаковых ступенек. Координаты начальной точки - X,Y, ширина ступеньки - HX, высота ступеньки - HY.

10-11 класс

Valya020482 02 марта 2014 г., 10:15:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cara1999ru
02 марта 2014 г., 11:27:51 (10 лет назад)

INPUT "N"; n
INPUT "x"; x
INPUT "y"; y
INPUT "HX"; hx
INPUT "HY"; hy
SCREEN 12
FOR i = 1 TO n
    LINE (x, y)-(x + hx, y)
    LINE (x + hx, y)-(x + hx, y + hy)
    x = x + hx
    y = y + hy
NEXT i

+ 0 -
Emelina
02 марта 2014 г., 14:02:04 (10 лет назад)

Язык?

+ 0 -
Lgor
02 марта 2014 г., 15:25:24 (10 лет назад)

Pascal,Basic

Ответить

Другие вопросы из категории

Как в этой программе задать свой промежуток от m до n а не от 1 до n

program z;
var n,i,j,s,mx,imx:integer;
begin
repeat
write('n>0 n=');
readln(n);
until n>0;
mx:=1;
imx:=1;
for i:=1 to n do
begin
s:=0;
for j:=1 to i do
if i mod j=0 then s:=s+j;
if s>mx then
begin
mx:=s;
imx:=i
end;
end;
writeln('Максимальную сумму делителей имеет число ',imx,' сумма=',mx);
readln
end.

Дана непустая последовательность натуральных чисел, за которой следует 0. Составьте программу нахождения суммы чисел этой

последовательности.Запустите программу на выполнение...(ПО ПАСКАЛЮ..)

Читайте также

Вариант 5. Точка на плоскости задана своими координатами X и Y. Построить таблицу, содержащую координаты пяти точек, для каждой

из которых необходимо определить, принадлежит ли точка заштрихованной области.

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.

Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в сле

дующем порядке: x1y1х2, у2, х3, у3, и т. д. Определить кольцо с центром в начале координат, которое содержит все точки.



Вы находитесь на странице вопроса "Изобразить лестницу из N одинаковых ступенек. Координаты начальной точки - X,Y, ширина ступеньки - HX, высота ступеньки - HY.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.