Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

напишите в паскале пжл

10-11 класс

Дано натуральное число. Определить какое из цифр встречается в этом числе чаще 0 или 9

рпрппроор 17 марта 2014 г., 6:31:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tasok2409
17 марта 2014 г., 7:34:20 (10 лет назад)

var s: string;
    i, z, n, a: integer;
begin
     readln(a);
     s := floattostr(a);
     for i := 1 to length(s) do
     begin
         if (s[i] = '0') then inc(z);
         if (s[i] = '9') then inc(n);
     end;
     writeln(z, ' ', n);
     if (z > n) then writeln('"0" > "9"');
     if (z < n) then writeln('"0" < "9"');
     if ((z = 0) and (n = 0)) then writeln('"0" = "9" = 0!')
        else if (z = n) then writeln('"0" = "9" = ', z);
end.

Только я тут испугался аж: всё правильно, а не так пишет х) Если ввести число, начинающееся с нуля, то первые нули отбросятся:)

Ответить

Другие вопросы из категории

Объяснить смысл следующих выражений:

1.Получить информацию.
2.Содержать много полезной информации.
3.Не содержать информации.
4.Информация к размышлению.

Помогите пожалуйста, оченьПомогите пожалуйста, очень надо.

заданны 4 квадратные матрицы A(n,n),b(n,n),c(n,n),d(n,n) в которых хранятся целые числа. Найти матрицы, в которых на диагоналях есть простые числа.

символ двоичного кодирования
2!=32 2!=256 как решить помогите!!!

Читайте также

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

Напишите программу (Паскаль):

выводится 5 строк, в которых сначала записан порядковый номер строки с точкой, а затем слово. вывести слова в алфавитном порядке.
например :
1.информатика
2.химия
3.математика
4.физкультура
5.литература
Вывод: 1.информатика
5.литература
3.математика
4.физкультура
2.химия



Вы находитесь на странице вопроса "напишите в паскале пжл", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.