Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сформировать массив с клавиатуры из N элементов (N - описываем как константу). Найти:

5-9 класс

а) произведение.
б) среднее арифметическое всех нечетных элементов массива.
в) максимальный элемент массива.
Выполняем в одной программе.

прпрпраптта 02 нояб. 2014 г., 11:22:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Angelina8501
02 нояб. 2014 г., 12:54:39 (9 лет назад)

const 
n=10;
var a:array[1..n] of integer;
i,max,p,sr,k:integer;
begin
p:=1;
max:=1;
for i:=1 to n do begin
read(a[i]);
p*=a[i];
if odd(a[i]) then begin sr+=a[i]; k+=1; end;
if a[i]>a[max] then max:=i;
end;
write('P=',p,' Sr=',sr/k:3:2,' max=',a[max]);
end.

Ответить

Другие вопросы из категории

Название операционной системы для мобильных систем, совпадающее с названием человекоподобного робота, - это...

А) R2D2, Б) киборг, В) android, Г) T1000.

помогите пожалуйста,сегодня нужно

Изначально

растровое изображение имело палитру 2 цвета. В процессе его преобразования
информационный объём увеличился в 8 раз. Сколько цветов стало в палитре?
ПОМОГИТЕ ПОЖАЛУЙСТА!КАК ПРАВИЛЬНО ОФОРМИТЬ И РЕШИТЬ?

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "Сформировать массив с клавиатуры из N элементов (N - описываем как константу). Найти:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.