Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дано число n. из чисел 1, 4, 9, 16, 25 ... , напечатать те, которые не превышают n. Срочно!

5-9 класс

НАстЮнЧиКА 02 марта 2015 г., 21:39:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Indirahafizova
02 марта 2015 г., 23:07:54 (9 лет назад)

var n,i:integer;
begin
read (n);
if (n>=1)then begin
for i:=0 to n do
begin
if (i*2+i*i+1)<=n then writeln (i*2+i*i+1);
end;
end else writeln ('Нет таких чисел');
end.

Ответить

Другие вопросы из категории

Читайте также

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

НУЖНО НАПИСАТЬ ПРОГРАММЫ НА ПАСКАЛЕ "циклы с условием" 1)Среди чисел 1, 4. 9. 16, 25,... найти первое число, большее n. 2)Дано число

n.

а) Напечатать те натуральные числа, квадрат которых не превышает n.

3) Дано натуральное число. Определить:

а) количество цифр 3 в нем;

г) сумму его цифр, больших пяти;

Дано число n

A) напечатать те натуральный числа , квадрат которых не превышает n
B) Найти первое натуральному число , квадрат которого больше n

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.



Вы находитесь на странице вопроса "дано число n. из чисел 1, 4, 9, 16, 25 ... , напечатать те, которые не превышают n. Срочно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.