Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите пож дана матрица 5на5 установить кол-во елементов больше заданного

10-11 класс

Assolь 12 окт. 2013 г., 2:30:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
поленька12
12 окт. 2013 г., 3:03:16 (10 лет назад)

 


const n=5; m=10;
var
a: array [1..n,1..n] of integer;
b,c: array [1..m] of integer;
d: array [1..m] of boolean;
i,t,k: integer;
Begin
repeat
for i:=1 to m do begin
d[i]:=true;
c[i]:=0;
end;
randomize;
for i:=1 to n do begin
for k:=1 to n do begin
a[i,k]:=random(9)+1;
write(a[i,k]:4);
t:=a[i,k];
b[t]:=b[t]+1;
c[t]:=c[t]+1;
end;
writeln;
for t:=1 to m do begin
if b[t]=0 then d[t]:=false;
if b[t]>0 then d[t]:=d[t] and true;
b[t]:=0;
end;
end;
for i:=1 to m do
if d[i] then write('число - ',i,' повторений - ',c[i]);
writeln;
readln;
until false;
End.

(также с выведением самих чисел...)

Ответить

Другие вопросы из категории

№1

Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:

•​ var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;

•​ if a > 0 then b := b mod 2;

•​ if b > 0 then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');

•​ end.

Доработайте эту программу таким образом, чтобы задача решалась верно.

№2

С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Var n,s:integer;

Begin
N:=0;
S:=0;
While s<=35 do begin
N:= n+1;
S:=s+4
End;
Write(n)
End.
Решите пожалуйста, надо с решением.

Access

1. Что такое запросы?
2. Что такое отчеты?
3. Что такое формы?
4. Что такое бланк запроса?

Читайте также

10 КЛАСС! ПАСКАЛЬ АБС!! СРОЧНО!! ПОМОГИТЕ ПОЖАЛУЙСТА! Дан массив А(n). Опередлите кол-во нечет элементов массиава, стоящих на

четных местах. выведите на экран исходный массив и найденное кол-во.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).



Вы находитесь на странице вопроса "помогите пож дана матрица 5на5 установить кол-во елементов больше заданного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.