Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1)Массив состоит из 40 элементов,нужно заполнить его случайными числами. ПОМОГИТЕЕ:С 2) Массив 30 эл-тов в порядке возрастания и убывания

5-9 класс

Xtn 13 мая 2014 г., 10:00:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Emily651
13 мая 2014 г., 10:47:29 (9 лет назад)

1)

uses crt;

Ответить

Другие вопросы из категории

помогите,пожалуйста))напишите блок-схему к этой программе(одномерные массивы)язык программирования-Паскаль.

Программа:
var a, b:array [1..15] of integer;
i, max, min, j1, j2, sum, k:integer;

begin
write('Измерения ростов всех студентов ');
randomize;
for i:=1 to 15 do
begin
a[i]:=random(50)+140;
write ('а[',i,']-',a[i],';');
end;
writeln;
write('Рост самого высокого студента (номер): ');
max := 0;
min := 65535;
k := 0;
sum := 0;
for i := 1 to 15 do
begin
if (a[i] > max) then begin max := a[i]; j1 := i; end;
if (a[i] < min) then begin min := a[i]; j2 := i; end;
sum := sum + a[i];
if (a[i] > 170) then
begin
inc(k);
b[k] := a[i];
end;
end;
writeln(j1);
write('Рост самого низкого студента (номер): ');
writeln(j2);
write('Средний рост: ');
writeln(sum/15:4:2);
write('Массив b:');
for i := 1 to k do write('B[',i,']',b[i], ';');
readln;
end.
Вывод:
Измерения
ростов всех студентов
а[1]-159;а[2]-183;а[3]-176;а[4]-168;а[5]-156;а[6]-165;а[7]-187;а[8]-144;а[9]-162;а[10]-164;а[11]-142;а[12]-158;а[13]-159;а[14]-163;а[15]-182;
Рост самого высокого студента (номер): 7
Рост самого низкого студента (номер): 11
Средний рост: 164.53
Массив b:B[1]183;B[2]176;B[3]187;B[4]182;
буду очень благодарна))

Помогите пожалуйста!

Современный монитор позволяет получать на экране 16 777 216 различных цветов.Сколько битов памяти занимает 1 пиксель?

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "1)Массив состоит из 40 элементов,нужно заполнить его случайными числами. ПОМОГИТЕЕ:С 2) Массив 30 эл-тов в порядке возрастания и убывания", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.