Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Подсчитать сумму чисел, больших заданного числа M из промежутка [A,B]. Найти среднее арифметическое этих чисел.

10-11 класс

Андрес 02 нояб. 2016 г., 5:47:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nrpavsch
02 нояб. 2016 г., 7:43:40 (7 лет назад)

(Програма для ЦЕЛЫХ значений(M,A,B))

Если else не сработает(а вдруг:)тогда место else напиши-\ if (m<a) or (m>b) then\) 

program M_suma;

var m,a,b,i,s,h:integer; se:real;

begin

s:=0; h:=0;

writeln ('Vvedit [A,B] ta chislo M');

readln (a,b,m);

if (m=>a) and (m<=b) then begin

for i:=m to b do

begin 

s:=i+s;

i:=i+1;

h:=h+1; 

end;

se:=s/h;

writeln ('suma chisel-',s,'  seredne ar.-',se);

end;

else writeln ('umova ne virna');

readln

end. 

Ответить

Другие вопросы из категории

Нужна помощь по информатике. Нужно решить карточку. Желательно подробно!! ! Вот карточка: Хотя бы

несколько. Кому не сложно помогите!! ! Тема называется Представление
числовой информации с помощью систем счисления!

Преобразовать формулу

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

Написать программу, которая считает и выводит на экран сумму всех целых чисел из промежутка [A, B]. Числа A и B задает пользователь.

Программу реализовать с помощью трех циклических алгоритмов:
1) Цикл со счетчиком for
2) Цикл с предусловием while
3) Цикл с постусловием repeat
В программе предусмотреть ситуацию, когда пользователь вводит значение B ‹ A
Пример 1:
Пользователь вводит числа A=5, B=10. Сумма чисел: 5+6+7+8+9+10. Вывод на экран: 45
Пример 2:
Пользователь вводит числа A=7, B=4. Сумма чисел: 4+5+6+7. Вывод на экран: 22
Пример 3:
Пользователь вводит числа A=5, B=5. Сумма чисел: 5. Вывод на экран: 5



Вы находитесь на странице вопроса "Подсчитать сумму чисел, больших заданного числа M из промежутка [A,B]. Найти среднее арифметическое этих чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.