Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых

10-11 класс

AlmatTS 02 дек. 2014 г., 8:48:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Walter299
02 дек. 2014 г., 9:49:01 (9 лет назад)

uses crt;
var a:array [1..10] of real;
i,k,m,n:integer;
begin
  clrscr;
  k:=0; n:=0; m:=0;
  writeln('massiv:');
  for i:=1 to 10 do
  begin
    read(a[i]);
    if (a[i]<0) then k:=k+1;
    if (a[i]>0) then m:=m+1;
    if (a[i]=0) then n:=n+1;
  end;
  writeln('отрицательных: ', k);
  writeln('положительных: ', m);
  writeln('нулевых: ',n);
end.

+ 0 -
КатяТ26
02 дек. 2014 г., 11:02:43 (9 лет назад)

Код Pascal 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22   var

Ответить

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Составить программу которая вводит с клавиатуры четыре целых числа a,b,c,d (каждое число - отдельной командой "ввод") и выводит на экране минимальное

среди них.Ничего кроме этого программа выводить не должна. При использовании системы Free Pascal для представления целых чисел используйте тип LongInt. Надо сделать в Pascal

(1) вариант

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел



Вы находитесь на странице вопроса "Вводить с клавиатуры 10 целых чисел, выдать на экран количество положительных чисел, количество отрицательных , количество нулевых", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.