Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Здравствуйте) Помогите составить программу вычисления значений функции в VBA, заданных несколькими условиями с использованием условного

10-11 класс

оператора If.... Then.... Else... , никак не даётся(((

Natashamostove 08 июля 2014 г., 3:28:37 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leshakarimov
08 июля 2014 г., 4:55:21 (9 лет назад)

uses crt;
var F:real;
    x,a:integer;
begin
     write('x:'); readln(x);
     write('a:'); readln(a);
     if (x>=0) and ((a>-1)or(a<2)) then f:=sqrt(x-sin(a))
     else
         if ((x>1)or(x<=3)) and (a<0) then f:=power(ln(13),3)-sqr(cos(x))
         else
             f:=(1+abs(x+a))/(ln(x-a));
     writeln(F);
end.

+ 0 -
мария274
08 июля 2014 г., 7:47:58 (9 лет назад)

А во второй строке натуральный логарифм в кубе?

+ 0 -
Kaz2001
08 июля 2014 г., 10:29:52 (9 лет назад)

да

Ответить

Другие вопросы из категории

15. Определите

результат выполнения программы:


var
i, sum: integer;

1)Строение задачи на паскаль.

2) условный оператор
3)цикл с предусловием

1.Передача данных через ADSL-соединение заняла 2 минуты. За это время был передан файл, размер которого 3 750 Кбайт. Определите минимальную скорость (би

т/c), при которой такая передача возможна. Пояснение. 2.На скольких дискетах емкостью 1440Кбайт можно разместить содержимое жесткого диска объемом 1 Гбайт??

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения

аргумента, вто¬рой — соответствующие значения функции: F(x)=xcos(1\x)+2 Решить нужно в паскаль.

Составить блок схему. Составить программу вычисления значений функции F(х) на отрезке [а;в] с шагом h. Результат представить в виде таблицы, первый

столбец которой - значения аргумента, второй - соответствующие значения функции.
F(x) =  \sqrt{x} ·  cos^{2} х.



Вы находитесь на странице вопроса "Здравствуйте) Помогите составить программу вычисления значений функции в VBA, заданных несколькими условиями с использованием условного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.