Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Здравствуйте) Помогите составитьЗдравствуйте) Помогите составить программу вычисления значений функции в VBA, заданных несколькими условиями с

10-11 класс

использованием условного оператора If.... Then.... Else... , никак не даётся(((

Sasha78787898 17 окт. 2014 г., 15:10:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
WarfaceLOL
17 окт. 2014 г., 17:39:16 (9 лет назад)

Скорее просто не хотите, что бы давалось.
uses crt;
var x,a,f:real;
begin
read(x);
if (x>=0) and (a>-1) and (a<2) then
f:=sqrt(x-sin(a))
else if (x>1) and (x<=3) and (a<0) then
f:=power(ln(13),3)-sqr(cos(x))
else
f:=(1+abs(x+a))/ln(x-a);
writeln(f:6:3);
end.

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста!! ) составить программу в "Pascal abc"!!)

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h.
Результат представить в виде таблицы, первый столбец которой — значения
аргумента, второй — соответствующие значения функции: "F(x) = 1/2 ctg x/4+4"

Составьте программу вычисления значение Sin, Cos и Tg углов от 0 до 45 градусов с шагом 1 градус (с использованием оператора цикла FOR). Для вы-вода

результата введите ограничение на количество знаков после запятой. Примечание. В Паскале используются стандартные функции: SIN(X) - синус Х (аргумент задается в радианах); COS(X) - косинус Х (аргумент задается в радианах); Для подсчета угла в радианах используйте формулу: угол в радианах = (угол в градусах)*/180. Результат представьте в виде: Программа вычисления значений тригонометрических функций x° Sin(x) Cos(x) Tg(x) 1 2 3 .. 45

Составить программу вычисления значений функции F(x) на отрезке [а; b] с шагом h. Результат представить в виде таблицы, первый столбец которой — значения

аргумента, вто¬рой — соответствующие значения функции: F(x)=xcos(1\x)+2 Решить нужно в паскаль.

Составить блок схему. Составить программу вычисления значений функции F(х) на отрезке [а;в] с шагом h. Результат представить в виде таблицы, первый

столбец которой - значения аргумента, второй - соответствующие значения функции.
F(x) =  \sqrt{x} ·  cos^{2} х.



Вы находитесь на странице вопроса "Здравствуйте) Помогите составитьЗдравствуйте) Помогите составить программу вычисления значений функции в VBA, заданных несколькими условиями с", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.