Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Составить и записать программу решения задачи: У Пети есть х руб. Петя купил несколько тетрадей и несколько карандашей. Вычислить стоимость

5-9 класс

покупки и сдачу.

Дарья2804 06 сент. 2015 г., 6:04:33 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ксюхель
06 сент. 2015 г., 8:05:02 (8 лет назад)

 

var
x, a, b, c, d : integer;
begin
randomize;
x := trunc (random (100)) + 200;
a := trunc (random (10)) + 1;
b := trunc (random (10)) + 1;
c := trunc (random (10)) + 1;
d := trunc (random (10)) + 1;
writeln ('У Пети ', x, ' рублей. Он купил ', a, ' тетрадей по ', c,' руб. и ', b, ' карандашей по ', d, ' руб.');
writeln ('Найти стоимость покупки и сдачу.');
readln;
writeln ('Стоимость покупки: ', a * c + b * d, ' руб.');
writeln ('Сдача ', x - (a * c + b * d), ' руб.');
readln;
end.

Ответить

Читайте также

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3

1)Составить алгоритм для решения задачи: Вычислить угол между двумя векторами, если эти векторы заданы своими координатами.2)Составить

алгоритм для решения задачи: Найти действительные корни квадратного уравнения вида ax^2+bx+c=0.

Помогите с информатикой! Нужно cоставить программу на языке программирования (Паскаль) с ветвлением

ЗАДАЧА - Составить программу решения задачи: Z = m/(m-1)
ЗАДАЧА - Составить программу определения четных (нечетных) чисел



Помогите составить программу решения задачи в паскаль АВС.

Даны два целых числа А и В (А меньше В). Найти сумму всех целых чисел от А до В включительно.

Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в

предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней



Вы находитесь на странице вопроса "Составить и записать программу решения задачи: У Пети есть х руб. Петя купил несколько тетрадей и несколько карандашей. Вычислить стоимость", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.