Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Dim i,s as integer

5-9 класс

S = 3
For i = 2 to 5
S = s + 2*i
Next i
Print s

Запишите значение переменной S

Rosmarie 29 авг. 2015 г., 0:53:52 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Notcka
29 авг. 2015 г., 1:47:42 (8 лет назад)

Текст просто содержит вычисление определённой суммы, а именно

 

S = 3 + (2*2 + 2*3 + 2*4 + 2*5) =         3 + 2*(2+3+4+5) = 3 + 2*14 = 31

 

именно это число и напечатает оператор Print S

 

Замечание  в первые скобки я поместил работу цикла.

 

Ответить

Другие вопросы из категории

Пятиклассник Вовочка однажды в кино увидел такую сцену – несколько мошенников обыгрывали зевак в игру с монетками. На столе находилась 21 монетка и

ведущий предлагал сыграть с ним по следующим правилам – нужно брать по очереди 1-2-3-4 монетку и кто берет последнюю, тот и проиграл. При этом ведущий благосклонно предлагал первым ходить игроку. Вовочка уже и не помнил про что был этот фильм, но вот игру запомнил и старается понять как это ведущий всегда выигрывает…Попробуйте и Вы понять, как правильно играть в эту игру и определить сможет ли ведущий выиграть у Вас, если Вы играете правильно при следующих количествах монеток на столе: 45, 53, 74, 113.В ответе укажите 4 слова с большой буквы Да или Нет. Да – если выиграет ведущий, Нет – если выиграете вы.

Решите пожалуйста номера 16 и 17

Читайте также

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык
Бейсик
Паскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s+11

кц

вывод s

кон


DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

s = s+11

NEXT k

PRINT s
Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s+11;

writeln(s);

End.

Решить задачу: Паскаль DIM k,s AS INTEGER s=2 for k=3 to 5 s= 2+k+s next k print s

Каким в итоге будет s?

DIM d,n, i AS INTEGER

n=4
d=n*2
FOR i = 1 to 3
d= d+ 2*i
NEXT I
PRINT d

записать значение переменной d. Спасибо.



Вы находитесь на странице вопроса "Dim i,s as integer", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.