Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пожалуйста! Помогите! В паскале сделать нужно, задание в картинке

10-11 класс

Завтра сдавать контрольную , помогите срочно(

BenDer2014 06 авг. 2016 г., 3:08:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dodged
06 авг. 2016 г., 4:28:19 (7 лет назад)

var
  a, b, h, x: real;
  i, n: integer;

begin
  writeln('Введите границы интервала (a,b)и шаг табуляции h:');
  readln(a, b, h);
  n := Trunc((b - a) / h) + 1;
  writeln('    x          F(x)');
  for i := 1 to n do
  begin
    x := a + h * (i - 1);
    if x<>0 then
      writeln(x:9:6, '  ', 2 * sin(1/x) + 2:9:6)
  end
end.

Тестовое решение:

Введите границы интервала (a,b)и шаг табуляции h:
-3 4 0.5
       x          F(x)
-3.000000   1.345611
-2.500000   1.221163
-2.000000   1.041149
-1.500000   0.763260
-1.000000   0.317058
-0.500000   0.181405
 0.500000   3.818595
 1.000000   3.682942
 1.500000   3.236740
 2.000000   2.958851
 2.500000   2.778837
 3.000000   2.654389
 3.500000   2.563686
 4.000000   2.494808



Ответить

Другие вопросы из категории

1. Исполнитель Черепашка, с опущенным для

рисования пером, выполнила следующую программу, вызванную командой фигура 1 10
6:

1. Составить программу, которая печатает заданное слово в обратном порядке.

2. Дано предложение. Определить число пробелов в нем.
3. Дано предложение. Определить порядковый номер первой встреченной буквы 'к'. Если такой буквы нет, выведите сообщение об этом.

Читайте также

пожалуйста помогите подскажите как делать такое задание в delphi

Нужно СЕГОДНЯ итак надо по номеру дня недели определить чем вы занимаетесь в свободное время.Можно написать любые занятия.
3 разные виды занятия.
Описать когда свободное время ,тоесть действия не определены.

СРОЧНО!!! Помогите пожалуйста с турбо паскаль, задание на тему циклы....

Как мне препод объясняла там должно быть for i:=1 to N do begin
P:P*(2*i)/(2*i+1)
end;
Вот часть которую нужно как то применить к этому заданию...
Как будет выглядеть весь код?)))

Задача по информатике (Паскаль)

Пожалуйста помогите сделать задание в паскале.







Дана
матрица А(3.3)

1)

Ребята, пожалуйста, помогите мне. Нужно сделать так, чтобы программы выделала имена, которые начинаются на большую букву и заканчиваются ласково на

"чка" (т е Леночка и т д) Нажмите альт и F11
ПОЖАЛУЙСТА ПОМОГИТЕ

и объясните как вы это сделали
п с имена придумывала не я, у нас пошлый учитель



Вы находитесь на странице вопроса "Пожалуйста! Помогите! В паскале сделать нужно, задание в картинке", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.