Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

27 баллов!!! Больше не имею!!! Пожалуйста помогите!!!

5-9 класс

Проблема: Надо создать программу в Паскаль который смог бы найти сумму элементов в каждом столбце. Это программа с Matrice и по моему с For.

Помогите пожалуйста, заранее спасибо!!!

MrXMan 12 апр. 2016 г., 14:37:42 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daniilarefiev1
12 апр. 2016 г., 16:23:40 (8 лет назад)

program dan777;
const n=5;
var a:array[1..n,1..n] of integer;
    b,c,k:integer;
begin
for b:=1 to n do
for c:=1 to n do begin
a[b,c]:=random(20);
write(a[b,c]:3);
if c=n then writeln;
end;

for c:=1 to n do
for b:=1 to n do begin
k:=k+a[b,c];
if b=n then begin
writeln('Сумма',c,'-о столбца=',k);
k:=0;
end;
end;
end.

+ 0 -
Ehlino4ka6682
12 апр. 2016 г., 17:54:40 (8 лет назад)

const n=?; m=?; {Размерность матрицы, вместо "?" ввести числа}
Var a:array[1..n,1..m] of integer;
s,i,j:integer;
Begin
 randomize;
 for j:=1 to m do
   for i:=1 to n do
     a[i,j]:=random(-100,100); {Заполняем матрицу случайными числами от -100 до 100, можно вписать любой промежуток}
 for i:=1 to n do
   begin
    s:=0;
    for j:=1 to m do
      s:=s+a[i,j];
    writeln('Сумма элементов ',i,'-го столбца равна ',s);
   end;
 End.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПЛИЗЗ, ОЧЕНЬ НАДО

система команд исполнителя вычислителя состоит из двух команд:
1-прибавить 2;
2-умножить на 3;
Составьте для вычислителя содержащего не более 6 команд алгоритм получение из числа 2 число 50

РЕШИТЕ ПОЖАЛУЙCТА! ОЧЕНЬ СРОЧНО! К 6-ти ЧАСОМ ВЕЧЕРА!!

составьте программу, проверяющую истинность утверждения "введенный с клавиатуры год относится к 21 веку". оформите вывод данных на экран, используя возможности модуля CRT.

Читайте также

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

Это не по уроку. Если у кого случалась такая ситуация, помогите пожалуйста!

Раньше у меня был комп, он был ну оооочень старый где то 2002г. Так вот, я решила скрыть папку со своими фотографиями и после этого я не смогла ни где их найти.
Пожалуйста помогите! Что сделать чтобы вернуть папку.

ПОМОГИТЕ, ПОЖАЛУЙСТА)

ЭТО ПРАВДА ОЧЕНЬ НУЖНО И ЧЕМ БЫСТРЕЕ, ТЕМ ЛУЧШЕ)
Объясните, пожалуйста, как мне сделать эти номера)
У меня на компьютере все папки есть, которые требуют в заданиях ( я про каталог Антона Павловича Чехова и т.д.), но только я понятия не имею, как это делать:(
Объясните, пожалуйста, если не сложно, конечно)
ЭТО СРОЧНО НУЖНО)



Вы находитесь на странице вопроса "27 баллов!!! Больше не имею!!! Пожалуйста помогите!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.