Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дан массив значений расстояния L в сантиметрах . Преобразовать значения , превышающие 100 см в метры , и округлить до целых .

5-9 класс

Dvorskaja1111 24 апр. 2014 г., 23:56:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Werser72
25 апр. 2014 г., 1:45:57 (10 лет назад)

uses crt;
const
     N=30;
var L:array [1..N] of integer;
     i:integer;
begin
    for i:=1 to N do
      begin
        readln(L[i]);
        if L[i]>=100 then L[i]:=trunc(L[i]);
      end;
    for i:=1 to N do write(L[i]:3);
end.
{но в выводе он наравне с метрами будет выводить и не преобразованные сантиметры}

Ответить

Читайте также

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.



Вы находитесь на странице вопроса "дан массив значений расстояния L в сантиметрах . Преобразовать значения , превышающие 100 см в метры , и округлить до целых .", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.